Nautilus Mini - Problem to replace coil and more


Recently I purchased a nautilus mini device which seems to be original (I checked with serial and the test was successful) . From the beginning of use I had lot of difficulties to re-close the tank after refilling e-liquid and sudently my Itaste VVP started to display a Zero resistance value so I tried to check what was wrong and I-ve seen that the middle of the device had to small filaments and in the middle of them some durty burned stuff . By trying to clean that out the filaments when out so now I think that I will need to replace the coil but I cannot unscrew the middle of device it seems that it is blocked (see picture)

Please help me ...thx

Pictures below :

  • 11 Comments sorted by Votes Date Added
  • Dear Customer,
    You pictures are too small,I can't see them clearly,I suggest you to send email to our service,attach some big and clear pictures,thank you!
  • It's hard to make out what you're talking about here, but I can tell you when you unscrew the base from the glass the coil should come with it. To help this process you want to firmly tighten your coils into the base and then apply a drop of your juice to the fat bottom gasket to aid with tightening/loosening.

    Your coil is stuck in the upper hardware and you will probably have to unscrew that coil with some pliers from the upper hardware, just be careful not to damage your glass. Then follow my tips above to prevent this from re-occuring.

    You can easily clean the glass and upper hardware, for the bottom hardware I clean it periodically with a Q-tip dipped in rubbing alcohol.
  • Unscrew the glass off the top portion. Then unscrew the coil out of the chimney, to protect the glass.

    You might have cross threaded the coil into the chimney. Which if you did... it's not good. Hopefully the threads in the chimney are still good, and only the coil threads are buggered up.

    Try threading a new coil into the chimney first, it should screw in easily, before reassembling normally. If the new coil doesn't thread in easily, you'll have to order a replacement "upper mini hardware". ... -p-79.html
  • How is it going with this? You really need to check and make sure your product is legit. I got to looking at those small pictures a little harder and it appears your coil is broken in half as well, there should not be so much metal attached to that upper hardware. We really need better pictures unless you've already resolved this.
  • You just needed to change the pixel size in your links.

    The bottom portion of the coil is missing along with the rubber insulator you shouldn't try to clean it just replace the coil. Sounds like you cross threaded it. Remove the upper hardware from the glass and then twist out the coil from the chimney of the upper hardware. If the coil is cross threaded then just buy a new upper hardware.

    Do not over tighten the tank to the base and add a few small drops of juice to the rubber gasket it will help when taking it back apart for refilling

  • What does the tray look like that's in the box that holds the tank? Is it gray paperboard or black plastic? Some of the fakes are coming up as genuine with the security code.
  • Hi,thegeodeman2005
    It is paperboard,details please refer to our weibsite:
    if the tray that's in the box that holds the tank is black plastic,which turn out that the product is a fake one.
    Thank you!
  • it's paperboard but the only weird thing is that I did not get any user manual with the box.. only the clearomizer the replacement coil but the problem is that I cannot unscrew the middle part from the glass.. Finally I tried to order another device and I will see.. if problem again I will buy directly from Aspire for avoid such troubles..

    I will update you after trying your suggestions as well. thx
  • HI , It's me again.

    I received another nautilus mini and this one looks totally different than the one I had problem with (the one related to this topic) .

    So now I am quite sure the 1st one was a fake product sent with a registered serial number because it came without user manual and even it seems that serial sticker has been added manually. Also the middle part cannot be unscrewed to replace the coil so it's definitely a fake I am now sure of it.

    The seller is showing partnership certificate and he's selling products on aliexpress so I think you may be interested to know about him :

    Also I bought the 1st one for 40$ and now he decreased the price to 29$.
    here is the vendor page :

    I opened a complaint with aliexpress and I hope I will get my money back.

    thx for your help
  • Yeah I see that he has a certificate posted I wonder if its legit? If he is a certified seller he should replace or refund your money.

© 2017 Powered by Aspire