Aspire Pegusas Mini won't respond

My Aspire mini Pegasus has stopped working, screen reads low resistance [with or without tank attached] Ive tried everything but it seems to be stuck in this mode. Any suggestions appreciated.
  • 5 Comments sorted by Votes Date Added
  • That error message would be normal if no tank was attached to the mod when the button is pressed. Like I said, it means the circuit is not closing, or there is a short.

    I'm glad you don't need the mod anymore though.
  • Check that your spring-loaded firing pin is moving freely. It should be stiff, but if you press it down it should spring back up. And make sure it is completely clean of any e-juice residue.

    Failing that, I would try a new coil and see if that helps.
  • Thank you for your response but I've tried that and still no joy!
  • Well, the error would indicate that you are not closing the circuit with your coil. Did you check the code online to ensure it is a genuine Aspire product? I would try to return it for an exchange.
  • It's definitely genuine Ive had it for 18 months no problems. Funny thing even when plugged into charger and no tank attached it still reads low resistance, if I remove the battery and then replace it Aspire logo appears and when button is pressed low resistance again, the mod seems to be stuck in this cycle. Not real concerned though haven't used it in 3 weeks and don't miss it so it served its purpose:) just curious.
© 2017 Powered by Aspire