Pegasus Problem, Check Atomizer

I receive my very first mod today , I chose the pegasus and a kanger sub tank mini v2 ( because of the triton leaking and I want to MTL). I went ahead and prime the 1.2 ohm coil of the kanger and proceed to screw it into the pegasus and it detect the ohm fine, fire a little bit ( 1 second max) then I want to check the menu like how to switch to TC mode and I hold the button for 3 second and it switch right away to TC mode. Here my problem I cannot switch it back to watt mode, the pegasus give me a Check Atomizer all the time, I try the RBA Coil .5 ohm and same thing, I try to premade .5ohm one and same thing check atomizer all the time. I check all the coil with a ohm tester and they all give me good ohm. There no way to switch it back in watt mode, everytime I try to hold 3-4 sec its always check atomizer.

Battery are fully charge in the 3.95v , I try to remove the coil and lite the display and reattach multiple time, same Check Atomizer. I try to screw them harder ( the coil and the whole tank) in case it was the contact.

So far my experience is very poor, what a bad way to get into vaping. I guess I will have to buy another pack of cigarette tomorrow... Anyone can help me ?
  • 9 Comments sorted by Votes Date Added
  • other people have had the same problem here few solutions :


     September 4 Posts: 20

    Taking the battery and replacing seems to have done the trick.
  • I tried remove the battery and lets the device sit for a least 1 hour, no joy , try the put the battery while holding power, its get into a wierd mode , its show me my last wattage used before I got stuck in TC ( 12W) but when I use the scroll wheel the V indicator is replace with F but its start at 300 and only go down to 200 and wont go back up, but when you press the fire, its return to TC anyway. Tomorrow I will go to a shop and buy a dripper , if the dripper do the same thing then its the MOD , if the dripper work then its the tank that maybe have a short 510 pin I guess , I hear some thing about the kanger mini short pin but only with RBA not with OCC , and the RBA brown insulator is the new one with a fix and that the one I got but in my case even OCC do that

  • Check big AL's post maybe that will help you. Pegasus wattage stuck. On the 1st page.
  • @GroupB Sorry you're having problems in your start into vaping. A couple of suggestions for you.

    The sub tank mini is probably not the best device to choose for MTL - that is how I vape and I could not get my STM to work for me on the 1.2 ohm without gètting very hot vapour and spitting, regardless of the watts setting - the Triton is much more adjustable and better suited for MTL as well as other methods - even if some of us have had a leaking issue, which can be 99% cured IF you can find which one of the multiple causes is the culprit!

    The 1.2 ohm coil is not a TC coil so the Pegasus should NOT have switched to TC mode anyway because the resistance is too high and it would not have exhibited the resistance ramp in value when the mod did its test fire @ 30 watts routine?

    It does sound as though you maybe have a connection problem somewhere in the coil/tank/mod which is why you keep getting the check atomiser error so yes it would be best to try a different tank if possible. Obviously if it can't now detect an atomiser resistance it is not likely to switch modes anyway.

    I note you tried the reset method when inserting the battery - did you actually keep the button pressed until the "Aspire" logo blanked?
  • I was about to buy the odyssey kit but you cant blame me for not buying the triton as a first tank , with all the leak thing around...

    Here whats happend, I put the 1.2 occ in , the pegasus gave me a 1.5 ohm , I press the fire very shortly to see if it was working, it did a little crackling 1 sec maybe less, I then hold for 3 sec and it switch to TC, and there was no fireing or nothing while I switch to TC , and yeah I dont have any nickel coil , was all with kanthal or SS whatever kanger coil are made off. Im not aware of any 30W fireing test it never happend.

    As far as connection go , I spend the nite checking that , trying every trick in the book to make the 510 pin longer and it did not work. but it always work on my ohm tester no matter if I try to make the 510 pin longer or not, so I have connection with coil/bottom of tank. I check with a feeler gauge and the center pin is .56mm on top of the 510 thread connector of the tank.

    I really think the floating pin of the pegasus is the problem.

    I did the trick for stuck wattage , the one you can read on these forum, no go

    I buy that thing online, Today I will go to a shop in my city and ask the guy to try different tank on it, If its no go I will contact the online shop and I hope I can get a refund and NOT a replacement , the pegasus look nice, but it plague with problem so far.
  • @GroupB Well it sounds as if your diagnosis might be correct. The only time I had a problem with the connection on STM is with the RBA where the bottom pin was a bit short.

    I still can't understand what made it switch to TC mode in the first place without having a low ohm nickel coil in the tank but if the mod is dodgy, who knows.

    Regarding the 30w test fire - the watts part of the display does not actually show this - so if you have a 1.8 ohm coil in there set for 12 watts instead of the voltage being 4.xx V it will show 7.xx Volts for the few seconds until it reads the coil whilst still telling you it is 12 watts which of course it is not - so unless you watch the voltage display you won't notice - other than the burning crackling sound from your tank of course!
  • I manage to lift the pegasus pin a little and put the tank in again , there is 110% contact with the bottom of the tank I am sure of it cause the pin after removing the tank got push in a little bit. There really something software going on. First with a kanthal my device switch right away to TC mode while holding 3 sec ... when you vaping your holding the button right... so there no way I was able to vape on that thing anyway.

    @Tina is there a procedure to reset the device to watt or not ? Why my device switch to TC without a temperature control coil ? Can you confirm its a defective unit ?
  • I fix my issue !
    My tank is now working perfectly fine... on top of a sigelei 75W . Im gonna ask a refund where I buy the pegasus or a least some credit in store.
  • @GroupB Failing that - another door stop!

    Glad you at least know where the problem was.
© 2017 Powered by Aspire