Pegasus "check atomizer" screen of death

I just received my Odyssey kit yesterday and had it all juiced up and ready to go. Took about 25 hits from the triton tank and I received the "check atomizer" alert. I unscrew the tank, checked the atomizer/coil and put back in. Still getting the alert... I even tried 2 different tanks and another coil. Any tips on how to fix it. I thought it might the 510 connection spring or something.
  • 6 Comments sorted by Votes Date Added
  • I am with charelz I have a 50w istick do that just plugged it in and rebooted. So I think if u remove the battery it might work.
  • Have you tried removing the battery and letting it sit for bit?

    I've had the "check atomized" come up, when swapping tanks. Every time when I looked, I didn't have the coil screwed in tight enough, an the center pin wasn't protruding far enough out to make contact.

    Only ONCE I couldn't get it to go away, but that's when I took out the battery for a bit and tried everything again, and it worked.
  • When in doubt.....reboot! :-B
  • I have removed the battery and let it sit for 24 hours before trying again. I have held the fire button while removing the battery. I used the usb cable to charge the device and try to do a hard reset. I checked the coil and tighten/ check the pin.
  • Hmm, have you tried to push gently on the 510 connector with a pen or something? The spring is pretty stiff, but it should push in and return nicely. Also check that the center pin on your tank protrudes slightly farther than the outer threads. That was the issue I was having with my Triton RTA. I did not have that issue with stock coils, however.

    Aside from that, this sounds like you should be contacting customer service...
  • I scraped the metal between the battery and the tank where they connect with a pin.... Has been working since. Temporary, but worth a try.
© 2017 Powered by Aspire