Atlantis CF Sub Ohm battery issues

I recently purchased a second Atlantis setup to supplement my first one. After receiving the system, I put the battery on the charger overnight. The next day, I used the new battery without any trouble and placed it on the charger overnight. The next day, I went to use the new battery and it seems to be stuck in Short Circuit Protection. When I press the button, it flashes three times in blue/pink. When I press the button three times to power it off, it gives the same three flashes as if it is powering off. However, pressing the button once again gives the same three flashes. When placing the battery on the charger, the charger stays lit green. However, pressing the button on the battery yields the same three flashes. I have been trying to troubleshoot this using my old battery as a reference, but can't figure it out.

Can anyone offer insight on this problem?

Thanks in advance,

  • 32 Comments sorted by Votes Date Added
  • edited August 2015 Vote Up1Vote Down
    I personally have the CF Sub Ohm Battery setup with my Atlantis V1 & Atlantis V2. I have fired, and use the Aspire .3 & .5 Ohm Coils, and have no problem vaping with the CF Sub Ohm Battery. The specifications of the Aspire CF Sub Ohm Battery will fire 0.3Ω - 1.0Ω Coils and when fully charged will push 40 Amps. I personally seem to get more Vaping time with 0.5Ω coils. But thinking that it could have been a recommendation that I read from this forum that mentioned using that specific Ohm Coil for best results. But you can use all three coils Aspire makes for the Atlantis on the CF Sub Ohm Battery.
  • edited August 2015 Vote Up1Vote Down
    @wcannon32 @charlzrocks The only thing I see why they would recommend using 0.5Ω coils with the Aspire CF Sub Ohm Battery is since the lower limit is 0.3Ω and the upper limit is 1.0Ω, is if your using those coils resistance can vary sometimes with coils. Example: if you're using a package 0.3Ω coils, you could get one with a resistance of 0.28Ω and it might might not fire because +/- 0.01Ω. So that's probably why they recommend using 0.5Ω coils for testing earlier in the thread because you were having issues with the battery. I personally haven't had an issue, and if anything the coils I've fired have been spot on or +/- 0.01Ω on some of my box mods but still fired fine on the CF Sub Ohm Battery.
  • Yes,our battery have Atomizer Short Circuit Protection:If heating coils are short-circuited while vaping, the LED lights (both colors) blink 3 times
    If you use the correct tank(Atlantis with 0.5ohm coil,not 1.0ohm or 0.3ohm),please reassemble the coil to the base hardware,make sure the coil must screw to the base hardware tightly to press the connection pin pop out to make good connection with the battery.

    If still not work,please change another coil to have a try,make sure the coil must screw to the base hardware tightly to press the connection pin pop out to make good connection with the battery.
    What's more,for a new coil,after assembling,please let the tank stand up for 3-5 minutes to let the coil soak up enough e-juice before using.
  • Tina,

    I have sort of the same problem only mine completely shuts off and will not hold a charge at all. I returned the 1st battery I purchased and now, not even 2 weeks later, this new one will not hold a charge and I am unable to vape. I charge it overnight and it last maybe 15 minutes before saying it is completely dead. I took the tank off and hooked it up to my spare battery (original one from smaller start up kit, not aspire). now that battery light is on, (the battery will not turn off & smoking if attached again). I am new to this so IDK if I should have done that with the aspire tank. Since this is the 2nd time this has happened what could be the issue?? Could something be wrong with the tank causing the battery to have problems? Also I changed out the coil 3x on the tank itself in the process of all this. I really do not know what to fix or replace, any suggestions ??
  • edited June 2015 Vote Up0Vote Down
    @Shelly78 Before answering your problem,i want you to see this suggestion first,we need more details,but we can not figure out from your original post:
  • Hi, I am having the same issue as original poster. I am using the aspire carbon fibre battery 17.4MM 1600 mAh with the aspire Atlantis 2. The battery without tank connected holds a blue light when pressed but as soon as the Atlantis is screwed on I get the 3 flashes of both colours. I took your advice and screwed in my 0.3 resistance coil tighter to the base but to no avail. I then screwed in a coil 0.5 resistance with the same results? I have a nautilus mini and I notice the pin sticks out further when the coil is screwed in making me think it's not connecting to the battery but if I screw either the coil or tank any tighter I'm going to break them. I am vaping a high vegetable glycerine content solution. Thanks would greatly appreciate any help.
  • I'm talking to seller think the problem is I've been sent the wrong product and isn't the Cf Sub ohm 2000 mAh I ordered but the reg carbon fibre 1600mAh battery which I assume wouldn't be compatible with subohm coils....
  • edited June 2015 Vote Up0Vote Down
    Indeed, a CF 1600mAh won't function with an Atlantis.
    And only the 0.5 ohm coil will do with the CF Sub Ohm.
  • Is there an alternative battery you know of compatible with the 0.3?
  • Not from Aspire (yet ?).
    Look around the box mods that can go up to 80 Watts power.
  • Ok thanks much appreciation
  • I have tried .3 and .5 ohm coils across two different tanks, all to no avail. All options work with my original battery without a hitch.

    Regardless of the inability to actively pass a current to the coil, the system will not power off. This indicates an underlying defect in the circuit of this individual battery.

    Seller has offered to replace free of charge, so that is the route I am going for now. Hopefully it's just a fluke.
  • shane0 said:

    I'm talking to seller think the problem is I've been sent the wrong product and isn't the Cf Sub ohm 2000 mAh I ordered but the reg carbon fibre 1600mAh battery which I assume wouldn't be compatible with subohm coils....

    Cegoca said:

    Indeed, a CF 1600mAh won't function with an Atlantis.
    And only the 0.5 ohm coil will do with the CF Sub Ohm.

    On the Aspire CF Sub ohm battery there is the Aspire name in yellow lettering near the bottom of the battery right under that it says CF Sub(ohm) in white lettering. If it doesn't say CF Sub(ohm) you got the wrong battery! (ohm) meaning the ohm symbol.
  • I keep reading to never run the .3 on the Aspire Cf subohm. I have ran .3 and .5 both fire and provide good flavor and cloud. I can tell the difference and like .3 better. Why is everyone saying to not run it?
  • Who is everyone? Where are you hearing this? The Aspire CF Subohm battery can fire from .3ohm on up to 1.0ohm according to the Aspire website information. I own 2 of these batterys and love them. There should be no reason you can't use a .3ohm coil with the CF Subohm battery. Aspire wouldn't say it was ok to do it if it wasn't.
  • Sounds plausible to me!
  • @Southy321 @charlzrocks

    The ASPIRE Atlantis coils are different regarding the Ohm law (previous post from Aspire somewhere ...) than any other usual coil.
    The CF Sub Ohm will of course detect the 0.3 and 1.0 coils, as mentioned on it's product sheet, but it's a waste of time trying to vape something out of them on that battery.
    Since you guys love to mention the product specifications, why don't you go to the ones for the Atlantis coils (and it's also on the box) :
    0.3 Ohm coils : from 70 to 80 Watts !
    1.0 Ohm coils : from 40 to 50 Watts !

    I can tell the huge difference vaping a 1.0 coil on a CF Maxx and in a Atlantis Mega at 30 Watts and at 45 Watts. 30 Watts is far from sufficient.
    Same observation for a 0.3 Ohm coil on the brand new Pegasus mod : it definitely needs the 70 Watts to vape correctly. At 30 Watts, nothing comes out the thing.

    But the 0.5 ohm only need 20-30 Watts (that's why they will work on the CF Sub).

    I think I have put theory and practice together here.

  • @Cegoca I agree that 0.5Ω coil is the best option hands down with the CF Sub Ohm Battery. I was typing early in the morning, I was just advising that you could fire those different Ohm levels. But your totally correct the vape production isn't on par or anywhere near what it can produce with a higher Wattage Mod. I use my IPV3-LI for 0.3Ω coils. Can't wait to try it with my Pegasus like you mentioned. It has the power to push above 20-30 Watt, which seems like what the CF Sub Ohm Battery likes to operate best at. You have a very valid point, I should have went into more detail earlier. Thks
  • @Cegoca Did you get the Pegasus mod, or are you going to hold on to see what's going to be released next?
  • Sure I got it, check my comments above and on the other tread, it's just awesome !
    I finally get to use the 0.3 ohm coils on a correct power, great ! ;)
  • I'm using carbon spinner 3 right now, planning to put an aspire atlantis 2 over it?
    Would it work fine?
  • Is that a sub ohm battery? If not it will NOT work. Do some research on sub ohm vaping over at the ECF. There are plenty of areas that will tell you what you need for sub ohm vaping. Basicly any coil that is below the standard 1.6 or 1.8 ohm is not sub ohm. Sub ohm coils usually range from .5 ohm down to .15 ohm and they are all different wire, some are Temperature do YOUR homework! :-B
  • I'm actually new to vaping and I've no knowledge about the ohms law.
    I would really appreciate if you could help me out.
  • I'm using the aspire cf maxx well trying to but my coils seems to not have good connection with battery when coils are off battery works perfectly fine but when I put them on the button would go from Blue to flashing blue and pink/purple I don't know what to do
  • @shaunr88 If the battery light flash from blue to blue and pink/purple,which means that short circuit protection.
    Please make sure the atomizer makes good connection with the base hardware of the tank,what's more,please make sure that the tank make good connection with the battery.
    If both of them make good connection with each other.
    Please change a new atomizer to have a try
  • I have a sort of same problem I recently got my aspire cf sub ohm and I tried it out but nothing happened I was told by the guy who gave me it that it had a safety feature where I had to press it twice... did that still nothing,, when I plug it in I notice it flashes three times pink/purple and then started flashing only blue for like 30 secs then shuts off completely. The charger light shows a red light meaning it's charging. Help do I need to get a new coil or what?
  • edited February 2017 Vote Up0Vote Down
    @d_martin14 Can the battery be turned on or off(quickly press the fire button 5 times in 2 seconds,the battery can be turned on or off)
    what's more,please make sure that you use the correct tank.the CF subohm battery compatible with the Atlantis tank with 0.5 ohm coil
  • Just wondering the cf sub battery pack is compatible with the cleito 120 coils because I'm
    Having the blue and pink blinking light problem
© 2017 Powered by Aspire