hi all, HELP PLEASE!! None of my aspire atlantis coils work!

Hi, I have an aspire cf mod with aspire atlantis 0.5ohm tank. its been working flawlessly for 2 months until i dropped it for the third time :( (accident!!) still worked though!! it was time to change the coil now and when i did the cf mod works but there is no noise or nothing from the tank!!! the blue light comes on when firing as normal but nothing!!! so i tried another coil then another.... i tried 6 coils!!!!! and nothing!! the coils are authentic aspire, i checked the security code on their website, authentic it said. so i decided to put the coil that needed replacing back in... hey presto IT WORKED!!!! i immedietly tried all the new coils NOTHING AGAIN, so i put the old one back in... AGAIN IT WORKED, making noise,clouds of vapour a bit of spitting etc. the only problem with the coil that needs changing but STILL WORKS is that its harder to inhale even with it set on the largest hole. WHY ARE NONE OF THE NEW COILS WORKING?!!!!! AND THE OLD ONE DOES? oh, i did prime all the new ones 1 by 1 as i tried them in the atlantis.
Thank you all
  • 3 Comments sorted by Votes Date Added
  • Dear angelo,
    Thank you for supporting aspire and sorry to hear that.
    How did you assemble the device?
    First screw the coil to the chimney then screw the tank to the base hardware
    Or first screw the coil to the base hardware,then screw the tank to the base hardware?

    Have a nice day!
  • I'll take a shot at this, a bit unorthodox method, but...

    1. Remove the coil from the base.
    2. Push the center pin on the base in with your thumb.
    3. Put the coil into the base, tighten it up.

    Now look at the center pin on the base, it should be have been moved out a bit when you screwed in the coil. This is a good indicator that the coil is making full contact with the center positive pin.

    If the center pin has not been pushed out when you tighten up the coil, then the "accidents" have taken their toll on your base. The reason why the old coil may still work, is that it is literally bent to match up any bending that the "accidents" have created.

    Also, when you screw the base and coil onto the tank, the chimney might be bent enough to 'pop' the new coil out of alignment from your 'accidents'. Again, the old coil might be deformed enough that when you assemble everything, it still makes the proper connections.

    That's about everything I can think of, right now.
© 2017 Powered by Aspire