Atlantis resistance issues.

Hello, I purchased a new Atlantis from my local B&M store and I absolutely love it. Great flavor and vapor production when it's working properly. However, I have already burned through 5 or 6 coils. The reason why is not from over use. I use them on an IPV2 at 25 watts and it reads the ohms as 0.6, most of the time. However, I've had an ongoing issue with the coils suddenly spiking in resistance. They'll hit at 0.6 one puff and the next puff it'll shoot up to 1.0+ ohms and if I don't catch it right away, it will instantly burn out my coil. It also fluctuates in smaller increments that don't cause as much of an issue, but it's becoming frustrating and expensive. It does it regardless of watts since I've tried running it at 20 watts with the same results. I've completely broken the tank down, cleaned it with rubbing alcohol and Qtips. I've removed and cleaned all threads and the replaced the 510 pin on my IPV2 and I've also tested other RDAs with no issues like I'm having with my Atlantis. I'll link some pictures at the end of my post, but I haven't seen anyone else having a similar issue. The only thing I haven't done yet is try my Atlantis on another VV/VW or mech mod since I have given them all to friends. Any advice or help?

Pictures of my readouts.
  • 3 Comments sorted by Votes Date Added
  • Have you just tried setting the IPV2 to just volts, and not watts? (I don't know the IPV2, just wondering)
  • Same problem with my IPV2 with the Atlantis. I try with other atomizers, without any problem. It does'nt work just with the Atlantis. Sometimes i have a resistance in 0,6, sometimes more than 1 ohm, and the coil burns ! If somebody have a solution ...
© 2017 Powered by Aspire