Aspire Atlantis Tank and CF Sub ohm battery

I purchased the Aspire Atlantis tank and Aspire CF SUB ohm battery 3 days ago. Work great the first 3 days now does not work at all. Battry is fully charged and nothing happens.
Comments
  • 4 Comments sorted by Votes Date Added
  • Dear Customer,
    Thank you for supporting aspire!
    Did the battery turn on? when your try to fire the Atlantis,did the battery flash? How many time did it flash?
    Please reassemble your device to have a try.Make sure that the coil was assembled to the base hardware tightly.

    If not work,please try another coil to have a try.

    Best regards!
  • Yes the battery turned on. And no the battery does not flash when I try to fire the Atlantis it stays a solid blue. I have tried reassembling the tank and tightening it up. I have tried a new coil and that did not work either.
  • Dear Customer,
    Please make sure not you need screw the coil to the base hardware tightly to press the connector pin under the base hardware pop out.

    Best regards!
© 2017 Powered by Aspire