Nautilus base pin problem

So searched this and other forums and couldn't really find an answer to it. The pin that comes out of the base of the aspire, I think it's spring loaded, that makes the connection to the battery from the coil has become flush or even slightly concave on my nautilus. This is causing me to get little to no connection and therefore no hit. I've tried popping it out from other side but it just goes back to what it was when I connect it to the battery. If it helps I have a vamo v5 and an SVD. Thanks to any who help.
Comments
  • 4 Comments sorted by Votes Date Added
  • Dear Customer,
    Maybe the spring is out of shape,it can not bear the loaded.
    You can buy the connector pin on our online store and fix it.
    The link is:https://online.aspirecig.com/aspire-nautilus-accessories-p-74.html

    Best regards!
  • I have read in several other threads here, a common problem with the center pin not sticking out all the way. It is commonly solved by screwing the coil head firmly into the base, this forces the pin to pop out just enough to make proper contact. Give it a try.
    I have also read some reports that the pin in the coil head itself may be out of tolerance and replacing the coil head with another may push that center pin out of the base.
    Hope this helps, let us know!
  • Awesome thanks for the replys. I will try and fix it if not I'll order a replacement part
© 2017 Powered by Aspire