Atlantis aspire and ipv3 box mod problem

Hello,

I am having an issue with my atlantis aspire that I just received in the mail yesterday. I am firing the atlantis on my ipv3 box mod at 25.0w and with 0.6 ohm. I keep getting a burnt taste with no flavor of e-juice. I currently have a flavor called strawberry deluxe from aspenvalleyvapes.com. I have tried different flavors too and with the same result. I wouldn't think the coil is burnt out already as I just got the tank yesterday. Could you please give me feedback at what I am doing wrong?

I let the tank sit overnight with e-juice in it so it should be primed and ready to go.
But keep getting that burnt taste for some reason. Thanks for your help in solving my issue.
Comments
  • 6 Comments sorted by Votes Date Added
  • Dear Hawkscubs2014,
    Thank you for supporting aspire!
    We don't have 0.6 ohm coils,did you miswriting the resistance of the coils?
    ipv3 box mod? Oh,the maximum wattage can reach to 150W or 100W.
    I have passed your problem to our engineer,we are worried that for some batteries the actual output wattage is high than the value showed on the battery(for example,the wattage value showed on the battery is 20w,maybe the actual output wattage is 25w or more high)
    Please reduce the wattage to have a try.(for example,20W)

    Sorry for the inconvenience!
    Have a nice day!
  • Take your coil out of the tank and inspect it to see if it is fully primed. I have been dripping liquid straight down into the Atlantis coils to make sure it absolutely gets saturated. Then reinstall the coil after dripping a few drops straight down into it.

    Once you fully saturate it this way it will feed normally.
  • I have an ipv3 box mod. Currently vaping at 20w. The atlantis is still producing a burnt taste and I've had the juice sitting in the tank for 1 day now. The batteries I have are samsung 18650 3.7v 2500mAh. They are both fully charged. I have primed the coil before use and it has been sitting in the tank with the e-juice now for 1 day. The juice is a 50-50 blend vg/pg.

    Any suggestions on what to do next? With the amount of money I have invested in everything, I would like it to work the way it is supposed to work. Thanks for your help
  • Dear Hawkscubs2014,
    Please try the lowest wattage ,which can fire our Atlantis on your battery,if 17w can fire our Atlantis,please try.
    Then make sure if you still get the burn taste .
    If your still get burn taste,please change the coil to have a try.

    Best regards!
  • About the Atlantis: If you once experienced burnt taste with a an Atlantis atomiser, then it means that this atomiser is done, no matter how long you let it soak afterwards, you will still get a bad taste. You need to use a new atomiser. Be very careful with these ultra-high wattage mods like the ipv3, firing an Atlantis at more than 50 watts can be enough to instantly damage the Atlantis atomiser. The recommended output is 20 to 30 watts, some people have pushed it to 40 watts with good results, but it's not recommended. Perhaps your ipv3 is defective. Put a new atomiser in your Atlantis, fill it with juice and let it soak for ten minutes, then try it on a mod that can't fire over 30 watts, or try it on a single battery mechanical mod: if you get good vapor and good taste, it means that the atomiser is good... Now put the same Atlantis on your ipv3, make sure that it reads 0.5 ohms, then set it to 30 watts and try it. If you get burnt taste, it means that your ipv3 is crap.
© 2017 Powered by Aspire