new device will not work

I just received my Nautilus starter kit and after following the user manual for the kit I am unable to make the device work.
I tried to ensure the battery was charged but I don't get the led response the manual says I should be getting. the charger led is a solid green but pushing the start button gets no response. I also filled the tank as per the manual instructions but nothing seems to work on this device.
what could I be doing wrong and is it possible I have a defective device? if I need to return the device for replacement what are the instructions for doing so? please e-mail your response to thank you andy nolan
  • 4 Comments sorted by Votes Date Added
  • Dear Nolanblue,
    Sincerely sorry for your problem.
    My colleague Abby will contact you and help you out.
    We need your help to take a video to show how do you assemble and use our products.
    Thank you and have a nice day!
  • Yan may need to turn on the battery.

    Press button 5 times in succession in 2 seconds. The LED will blink 3 times (both blue and orange lights) and the button will illuminate Blue when press the button.

    Repeat this procedure to turn battery OFF
  • I have tried pressing the button 5 times in succession in 2 seconds and nothing happens. I think I may have a defective do I get a replacement battery? I also filled the tank per the instructions with fluid I purchased from a site recommended from a person here on this forum but without the battery working nothing will happen. its very frustrating..please send me advise on replacing the battery and also any diagrams showing how everything should be set up for a correct charge. I don't have the ability to send a video or what I'm doing but I can assure you I have been using the instructions provided by the user manual for the starter kit
© 2017 Powered by Aspire