Flooding in Nautilus

I've already sent an email about this, but I noticed after that you require that I use a form with it, so I decided to just post here instead, I hope that is okay.

I’m having some problems with my new Nautilus, and the vendor I got it from is not being very helpful, he tells me that I’m not using it correctly. I will try to explain my issues here as clear as possible, but english is not my main language so there are some things I dont know the names of.

I will first explain how I’m using the tank:
I usually only fill the tank to about 2.5ml of juice. When assembling I insert the cartomizer/coil and screw it on firmly, but without using force. I also make sure to close the air holes when putting the bottom piece on the tank. I will then open the air holes again, and let it sit for a while, once I let it sit over night, once I let it sit 20 minutes, just to make sure the coils have juice in them. I also usually take a few primer puffs with the smallest air hole, but I have noticed I never get air bubbles when I do this, I understand that I'm supposed to get a few bubbles after priming.

My first puff is filled with liquid, I thought it was just in the “pipe” so I did the trick where you hold a paper towel over the drip tip and shake, to get excess juice out. Give it a minute and it’s flooding again. When I take it apart to inspect, there is no juice on the battery input part, but there is flooding in the hole below the cartomizer/coil part. That is the part where the air holes are.

I have tried 3 different cartomizers, the first 2 was the one installed and the extra that came with my nautilus. The third I tried was an extra I bought when I ordered the nautilus, it is the improved version (BVC).

I have taken it apart several times, I have tried screwing the cartomizer on a little less tight/tighter, you name it I have tried it. I do not have any of these issues on my aerotank, my iclear tank or my evod tanks, so hopefully it’s not just me being an idiot, I’m very sure there is something wrong with my nautilus.

I've checked and my nautilus is genuine.
  • 2 Comments sorted by Votes Date Added
  • I have had kind of the same issue, I just got my nautilus mini about 2 weeks ago and I have gone through 4 Coils for it. After about 2 to 3 days my coil will flood, and after a short time I am no longer able to get and vapor off of it at all. That is the first 3 anyway, the 4th doesn't work, my mod reading "low Res". When your product works, it is amazing but going through 4 coils in 2 weeks is a little much. I am using a 50/50 e-liquid mix, I have another tank that I use and I have never had a problem with the juice. I do not have my mods turned up too high and I am not sure what the issue is. And now I can't use my nautilus mini because the glass tank broke on me. Not sure how that happened, I baby that tank due to the amount of money I spent on it and now the glass is broke in half after sitting in my bag on my way home from work. Nothing heavy on it and it's never been dropped. I have not spent this much money on a product and had these terrible results before but the Aspire Nautilus Mini is not worth it. Monitors, do not tell me how happy you are that I bought your product because I am not happy with it, of course you are happy with my money. I do not plan on buying any other Aspire product after using this one. I do plan on informing anyone that I meet about my experience with your product. Thank you for your time.
© 2017 Powered by Aspire