Tigon - problems changing coil

Hi - I bought an Tigon kit 3 weeks ago and went to change my first coil yesterday. According to the instructions "coil replacement is just a case of unscrewing the base hardware" - however it is completely stuck and unable to be removed. looking at various websites i have tried: running under hot water, placing in the freezer, rubber bands, rubber gloves, tapping the base on a hard surface etc all to no avail!! This morning i tried again and the glass tank broke in my hand as i was trying to unscrew the base. I then decided it was time to use a lock wrench (with a layer of rubber to protect the finish)- however even this was unsuccessful!! Now i have a broken glass and the base is still stuck tight.
Help
Comments
  • 1 Comment sorted by Votes Date Added
  • Hello Vaper,

    If you have any question refer to Aspire Products, please feel free to contact service
    Service@aspirecig.com
    They will seek suggestion from Aspire engineer for you.

    Have a nice day!

    Best Regards
    Aspire Team
© 2017 Powered by Aspire