SkyStar Revvo will not charge

My daughter has the following setup, bought in February 2019:

Aspire SkyStar Revvo Kit
Extreme Vaping 18650 3000mAh High Drain Battery x2
Coil Master KBag Mini
E-Cig USB to 3 Pin Plug Adapter

Everything used to work well. Now the vape is dead and will not charge. I have tested the charger and cable on another device and it works fine. However, the vape display does not light up when the charging cable is inserted and there is no indication that it is charging. The fire button does not work either.

Any ideas?
Comments
  • 6 Comments sorted by Votes Date Added
  • @man_with_a_problem If you tried above suggestion and it still doesn't work, please feel free to contact service@aspirecig.com

    They will seek suggestions from Aspire engineer for you.

    Best Regards
    Aspire Team
    charlzrocks
  • Thanks everyone. I ordered some Sony VTC5a's and an external charger from 18650.uk and the vape is now working again. I've recycled the old batteries.
    charlzrocks
  • You may have accidentally put the mod into stealth mode. press the fire button 3 times to go in or out of stealth mode. the screen should light up. Also, have you tried new batteries? Using the wall block that you have may have worn out the batteries prematurely. You should never use a wall block that is meant for a cell phone as they operate between 4-6 amps and your device is only supposed to be charged at 1-2 amps. Also, only charge the mod when the batteries are close to being depleted as charging them on a daily basis regardless of their current charge status will shorten the battery life. In other words, don't charge them every night unless you have to! Let us know what happens!
  • Thanks charlzrocks. I have tried getting out of stealth mode but no luck. Your comment about using a wall block meant for phones might be a good pointer - that is what we used. I'm about to order some Sony VTC5a's and a Nitecore charger from 18650.uk so hopefully that will get the mod working again.
  • Ok, let us know how it goes!
  • Awesome news, glad your SkyStar is working again!
© 2017 Powered by Aspire