New Breeze 2 units(2) not firing

I had a Breeze 2 for about 6 months, and it worked great, but all of a sudden stopped working, thought it might be the battery, so ordered a replacement, and an extra as my wife wants to quit smoking. In addition to the new batteries, i ordered 3 of the leak proof pods, and a few packs of atomizers.
Having experience with the Breeze 2 in the past, i charged both batteries and filled the new pod. I left the pod to sit overnight so as to make sure the juice had properly saturated the pod. When i went to use it the next morning, nothing happened, would not fire. I tried the pod in the other battery, same thing.
I had another pod that I just replaced the atomizer a few days before, and filled it, so it had been sitting for a few days, and again, nothing on either battery.

Any help would be appreciated as i was really looking forward to getting back to using this again. When i received my Breeze kit 6 months ago, it was up and working within a few hours, so not sure what could be the issue here. I can see that when plugged in the lights on the unit do light up, so i know that it is charging, and i left the unit for a few hours to get a good enough charge so i could use it.
Comments
  • 4 Comments sorted by Votes Date Added
  • When charging a mod battery DO NOT USE your CELL PHONE wall block! They are rated for 4-6amps coming out of the wall and the mods that you get from nearly anywhere are rated at 1.5 to 2 amps. You should not have to charge a new mod from Aspire as they should come charged from the factory. Only charge the mod when the unit calls for it or you could shorten the life of the battery. This all being said, my question to you is "Did you try the unit before you put it on the charging cord?" Did it fire? Did you check the scratch off for Aspire authentication? Your only recourse is to return it to you retailer as a DOA unit. I do not mean to sound condescending regarding the charging of your mod, but there are so many vapers out there that are not aware that you can ruin a battery by charging it incorrectly. Good Luck!
  • I did try to fire the device on arrival, nothing happened, which is why I figured it needed to be charged.

    I've only ever charged my devices through a low amperage computer USB hub as I am aware of the danger of ruining batteries.

    I did check for authenticity, it did say they were authentic. I ordered the batteries, pods, and atomizers directly from Aspire store.

    Unfortunately, I just found in the warranty center that the items must be returned in the original box, which i no longer have. So my only recourse is to buy new batteries... again.
  • @charlzrocks
    I remember now that I did a verification on the pods, and atomizers, all of which did authenticate. However, the batteries came in bags with Aspire tags on them, which did not contain the "Genuine" labels or a verification code on them. It just had the QR code, which is the same on both tags, just goes to the Aspire website.

    At first, I thought I had disposed of the "boxes" the batteries came in, as I could not find them, but then remembered that they actually came in bags. All other items ordered (pods, atomizers) came in boxes.

    So, my question is, are the tags sufficient enough to return as a proof of purchasing a genuine Aspire product?
    Photo on 6-29-19 at 11.33 AM #2.jpg
    1080 x 720 - 250K
    Photo on 6-29-19 at 11.33 AM.jpg
    1080 x 720 - 228K
  • depends where you got them. Most retailers require at the least a receipt. If you got them from the Aspire online store, check with Aspire customer service to see what might be done.
© 2017 Powered by Aspire