Loose connector

I got my Skystar a couple of months ago and noticed the connector for the tank in the top of the device has gotten loose and has play in ot. Im talking about the round insert that the tank screw in to. Is that a pressed fit or are there internal screws or a nut or something that holds that in? I've never dropped it or keep it in my pocket or anything.
evdev
0311192212.jpg
4160 x 3120 - 3M
Comments
  • 5 Comments sorted by Votes Date Added
  • evdev said:

    Hey @joe did you ever manage to find a fix? My SkyStar has basically became unusable over last week as the top plate has gotten so loose that it can't recognize when a tank is connected.

    The only way to tighten that top piece that I could think of was to disassemble the whole mod via the star screws underneath the batteries BUT who has that kind of screwdriver laying around....Any tips would be great!

    I fixed it, you can read how in this post: https://forums.aspirecig.com/discussion/31168/skystar-defect-loose-tank-connection
    charlzrocks
  • Dear Sir,

    If you can not get the suggestion for your problem, please feel free to send detailed information about your problem to Aspire service
    service@aspirecig.com

    They will check with Aspire engineer and give you the suggestion from our engineer

  • Hey @joe did you ever manage to find a fix? My SkyStar has basically became unusable over last week as the top plate has gotten so loose that it can't recognize when a tank is connected.

    The only way to tighten that top piece that I could think of was to disassemble the whole mod via the star screws underneath the batteries BUT who has that kind of screwdriver laying around....Any tips would be great!
  • evdev said:

    Hey @joe did you ever manage to find a fix? My SkyStar has basically became unusable over last week as the top plate has gotten so loose that it can't recognize when a tank is connected.

    The only way to tighten that top piece that I could think of was to disassemble the whole mod via the star screws underneath the batteries BUT who has that kind of screwdriver laying around....Any tips would be great!

    His problem is not the same as yours, as his is the 510 round connector ring only, not the entire top plate like yours. Again try the service email....maybe @joe will respond back as to what happened with his, the OP was from March of last year so.......
  • @KimVE Thank you for sharing the fix
© 2017 Powered by Aspire