Broken help

My breeze 2 wont charge, or burn it just blinks red and blue same time. Blinks red and blue Simultaneously when plugged in for 3 blinks then pause the about 10 blinks both colors again then stops. I cleaned Port and plug, tried different power sources like laptop, I'm using intended wire that came with and tried my breeze 1 wire, and loosened coil which is 2 days old with no avail. Only 3 months old. Please help.
Comments
  • 1 Comment sorted by Votes Date Added
  • You may have a bad coil or a fake coil. Did you check the scratch off on the coil box? From what you are telling me, the unit is indicating that the cord has been connected (3 flashes) but the 10 flashes is not indicated anywhere in the user manual. Make sure that you are using either of the coils that are made for the device (1.0Ω or 0.6Ω) as using another coil resistance could be causing the problem. Other than that you should contact Aspire Customer Service at service@aspirecig.com
    They are away on Holiday until February 18th so a reply may take a while.
© 2017 Powered by Aspire