Nautilus AIO no suction

I purchased a Nautilus AIO about a month ago. It worked fine (vaping, filling, changing coils) for around 3 weeks. The last time I changed the coil and filled it, there was no suction. It was like the airflow was completely closed, but it was wide open. I tried everything - I cleaned the entire pod, installed a new coil, etc. Still the same problem. So, I ordered 2 replacement pods. The very first time I changed the coil on one of the new pods, I encountered the same problem. No suction. This is really frustrating. I am now on the 2nd new pod and it is working fine, but it is the only one I have left. I really do not want to keep replacing pods to have them keep failing. Can someone please tell me why this keeps happening?
Comments
  • 2 Comments sorted by Votes Date Added
  • @Tina... this could be a coil base problem as described by @woodbar !
  • @charlzrocks We have explained to woodbar, From the photos he posted, the replacement coil he bought is fake, he need check with the seller for refund or replacement

    @LittleBelle Would you please check the extra coil you bought, if it is different from the original coil installed inside the pod?

    What's more, if you have any question with aspire product, please check with our service department
    service@aspirecig.com
    They will check with aspire engineer and give the professional suggestion




© 2017 Powered by Aspire