FW v2 update problems for SkyStar

Hi ,

today I tried to update my SkyStar (v1) via a PC of a friend (cause usually I am a MAC user running on High Sierra which isn't supported (don't know why) – without success ☹ Is there any trick?

What I did: run the installer, launched the App on the PC, Aspire SkyStar was switched on and waited. Then there was a Microsoft sound and few seconds later the USB sign on the display of the Aspire. It also immidiately started charging. But there was no launch oft he device itselft which showed me the actual Firmware version, Device name and Hardware version in the Application. And I also couldn’t choose the update file from the Application.

What am I do wrong? Cannot be that difficult.

Regards,

Frank
moritz2k
«1
Comments
  • 50 Comments sorted by Votes Date Added
  • Hello Everyone,
    Thank you for the information. our service checked with our engineer, some parts of the bin file have missed, our engineer is dealing with it.
    If any updated information,we will share with you here at the first time.

    Best Regards
    charlzrocks
  • Thx @Tina for your involvement and keeping us informed. Now we are on track with great support and movement at the development team.
    Tinacharlzrocks
  • You aren't doing anything wrong Frank...

    It's the V02 update file. It is supposed to be 2mb in size and it's 86kb

    I can upgrade/reinstall firmware V01 by using the .exe here:
    C:\Program Files\STWProduct_egt\Release\STWANDDKY_USBUpdate_exe\OutExe_stwDky

    called: ECU_Upgrade.exe

    The file for V02 is the issue, it's not complete.


    Anyone from Aspire have the proper V02 file to share? and update the support section for the Skystar?
    iFranky
  • Welcome to the club! But I have to admit that "Alice" is eager to help. Today I got two important informations:

    "Now we know why at the first several times , the application window can not show firmware,hardware name .
    You need to install and run the application file firstly,then connect charging cable.

    If you have connected charging cable with Skystar mod at the begining,then install application file,it will not show current firmware and hardware name.
    But you can unplug charging cable and re-connect it with Skystar mod. Then the application file will detect mod normally.

    For the file error message when you choose bin file,our engineer will check and improve the BIN file later
    ."

    So that's good to know for others/beginners (like me) ;-) Regarding to the .bin file I got the identical info like you:

    "Currently ,I'm not sure the root cause,but I will pass your case to our R&D department. Sorry to bring you unpleasant experience and inconvenience."

    So lets wait when their software development team solved the problem... =;
  • iFranky said:

    Any news here? After posting clear instructions to replicate the issue and what the problem is Aspire now had time to correct the corrupted files. Is there any WORKING update now for us customers?

    I don't get how this is a week long thread either :-( Especially why Aspire don't give proactive status updates :-(

    Relax they are working on it. Good things come to those who wait. When @Tina has news she will post it. Badgering her won't make anything go any faster. They are working on it.
    Tiber
  • Hello everyone,
    We just updated the file for the Skystar for windows, we checked that it works on our PC with windows operating system, please help check if it works on your pc with windows operating system.

    Please wait in patience, our engineer is dealing with the file for MAC system

    Thanks &Best Regards
  • @PT1971 @iFranky thank you so much for the feedback
    Our engineer is dealing with the MAC file, if any information,we will share there at the first time ;)
    charlzrocks
  • desTROYer said:

    I am using a Windows 10 PC and the firmware update software does not recognize the Aspire mod. The application is displaying blank for the device name, firmware version and the hardware version.
    I don't have access to an older OS to verify if this is a driver issue
    Thanks for the help

    Problem solved by using this app instead:
    C:\Program Files\STWProduct_egt\Release\STWANDDKY_USBUpdate_exe\OutExe_stwDky\ECU_Upgrade.exe
    charlzrocks
  • Roger that. Thanks for clearance
    Tina
  • edited July 29 Vote Up0Vote Down
    Thx for the feedback. But I am unable to simply launch the Aspire Update Application, that's the main problem. I cannot choose the V02 files cause the Aspire and PC won't connect correctly.

    On YouTube a guy said something about first pull out the batteries, connect and then plug them in again Is that correct? Unfortunately I cannot test it again cause already at home again on my MAC.
    But if this would be the right way, why Aspire doesn't tell you - see here https://blog.aspirecig.com/how-to-update-the-firmware-of-aspire-mods/ I mean nothing more simple than that...
  • Nah that's for older Aspire Models. You can upgrade just by plugging it into a USB cable. It doesn't have to be switched off, without batteries or anything.

    goto C:\Program Files\STWProduct_egt\Release\STWANDDKY_USBUpdate_exe\OutExe_stwDky

    and open ECU_upgrade.exe

    it will show you that it recognizes your Skystar.

    What i was saying in my last post is that you won't be able to upgrade regardless because the v02 file on their site is incorrect.
  • edited July 29 Vote Up0Vote Down
    Exactly this is my problem: the PC recognizes my Skystar (can hear that typicall Microsoft sound and also see a USB symbol on the diplay of the SkyStar) but does not show anything else in the programm. Attached you see the same like on my MAC: everything is empty https://d.pr/i/oYsvGG

    I would be glad to minimum be able to select the incorrect v02 file. But even this is impossible. Or do you say that the installer doesn't show Firmware version, Device name and Hardware version just cause the fw update file is incorrect? I don't think so.

    I am wondering why Aspire don't give any support feedback like "Hey, we know about this issue and will solve in x days/weeks". Not very userfriendly...
  • edited July 30 Vote Up0Vote Down
    You are missing the point a little bit Frank. The updater and the firmware are broken. It's 100% not a problem on your end, it is an issue with the software. I have confirmed this on my older Aspire box mods which update fine using older versions of the updater and (obviously) different firmware.

    Only thing to do is wait for an answer from Aspire (if they ever reply)
  • Hi Tiber,

    well, I'll give it a last try today. I got feedback from the ASPIRE Support USA and they said:

    Hello Frank,

    What's your exact computer system version ? Please ensure you use original Aspire charging cable that comes with Skystar mod together.
    I just use my windows 7 ultimate version computer to upgrade Skystar firmeware from V01 to V02 and complete the upgrade successfully without problem.
    You can also change USB port of computer to try. Some USB port of computer only has charging battery function ,can no transfer data.
  • Hi Tiber,

    Hi Tiber,

    I now have been at a reseller store here in Germany http://tantedampf.de Like you already explained also the tech specialist from „Tante Dampf“ said the files are corrupted and there is no firmware update possible! It’s on Aspire to solve this problem. So I wonder how their support could tell me to successfully manage the update while a professional guy like him who is doing things like this nearly every day isn’t.

    All in all it’s time to officially tell Aspire HQ about this issue – as far as it isn’t already known.

    Regards,

    Frank
  • It will be because the Aspire guy probably used a file he has on his PC and he didn't download the one from the support site.

    Aspire need to get a proper software developer to sort their update software and firmware out because this isn't the first Aspire product I've had this issue with.

    @Tina
  • edited July 31 Vote Up0Vote Down
    Interesting feedback:

    "Hello Frank,

    The V02 firmware of Skystar for windows that uploaded at our official website is not broken.
    If you download and installed firmware for other model mod in your PC before,please delect and unload it firstly,because you can not use it to upgrade for Skystar.
    Ensure you download and install firmware from our website correctly.
    Here is link:
    https://www.aspirecig.com/upgrade/SkyStar/514.html

    When you use charging cable to connect Skystar mod and PC,the screen of Skystar mod will diplay USB sign,that means the PC will transfer data to Skystar mod normally.

    There are two files after you uncompress RAR file.

    Install the file"aspire UpdateVV1.5_Setup(4)" firstly."


    Then click “Aspire-Update” icon to open it ,click "OpenFile"button,choose file"SkyStar210_S_V02.bin ",click "Update" button,complete upgrade.
  • edited July 31 Vote Up0Vote Down
    They are absolutely talking crap.

    Reinstalling V01 works absolutely fine using the actual .exe file in the folder i listed above.
    Their V02 is 100% broken, why the hell are they denying it?

    Take a look at this screen shot (right click and open in new tab to see it full size)

    https://i.imgur.com/wVQKs5j.jpg

    There is a 1.9mb difference between the two .bin (firmware) files.

    Ask them the file size of their V02 file, I would put money on it being 2mb in size and not the 86kb that downloads from their site.
  • claro que esta roto el archivo lo he descargado por explorer chrome firefox en diferentes pc y nada da error
  • Hello Everyone, thank you for the suggestion and tips, if your problem can not be solved here,please feel free to contact our service
    service@aspirecig.com
    Our service will check your problem with our engineer and give the suggestion from our engineer /:)
  • edited August 1 Vote Up0Vote Down
    Today I tried to install the FW update for its 5th time now - still without success :((

    It was a totally new install of the "aspire UpdateVV1.5_Setup(4)" on a very new PC. After clicking on the “Aspire-Update” application to choose bin file, the upgrade stopped cause I could choose the update .bin file (OpenFile), BUT the „Update“ button won’t become active to run. See screenshot here https://d.pr/i/iZ13sI

    Sorry, after so many tries, after so much feedback from others here Aspire definately has to check it!!! And also has to stop denying it don't you agree @Tina
  • edited August 1 Vote Up0Vote Down
    @iFranky Yeah, you used the .exe file in the folder? That's where i got up to. The update .bin file is 100% the issue.

    @Tina you guys really need to download the file from the site and try yourselves before telling us to go to service with the issue. Ifranky already tried that and they told him it was a problem on his end when it's not. It's the update file, it's broken.

    How many times do I need to type the same thing and repeat myself?

    SORT THE UPDATE FILE OUT, IT IS BROKEN
  • edited August 2 Vote Up0Vote Down
    @Tiber @iFranky Thank you for the suggestion. We have tried before uploading the file to our website. But while users trying updating the firmware may meet a different situation, so we suggest that if your problem can not be solved here, please tell the detailed information to our service : service@aspirecig.com
    our service will check with our engineer for the information you provided and find out the reason and solution.
    Thank you again for the suggestion
  • Same exact problem here iFranky, per your illustration. I wrote Aspire Services as Tina suggested, and we went back and forth with questions and screenshots.

    Today, I got this response:

    "Currently, I'm not sure the root cause, but I will report your case to our R&D department."

    And so we wait?



  • Hi, I also posted this problem in the "Download" section of the forum on July 26th and described the corrupt bin file. Sadly my post was deleted after a few days without any information. I just reposted it just now in the Downloads section, now I found this thread.
    I'm somehow a little bit frustrated about that. Errors can always happen but to not accept them when many users report them is not very customer friendly. Thought I bought "something better"...

  • @moritz2k Well said, I totally agree!
  • Thanks for deleting my post. nothing like a bit of censorship to cover your backs. GG
  • Tiber said:

    Thanks for deleting my post. nothing like a bit of censorship to cover your backs. GG

    I deleted your post as Profanity is not allowed on the Aspire Forum. Please read the rules. I have no problem with posts that are negative with regard to product problems, etc., however, profanity will not be tolerated. Thanks for your understanding.
  • @charlzrocks Can you not understand my frustrations? I'm just some guy on the internet and I figured out the issue in 5 minutes of originally downloading the update.

    I then post on here with clear instructions to replicate the issue and what the problem is.

    Only to get a cookie cutter reply to get in touch with service. This is after someone posts in this thread saying they already have and got a cookie cutter reply about making sure you run the program first etc.

    You guys are a massive, if not the biggest player in vape hardware and I get told to do the leg work (which previously stated leads to cookie cutter replies from service) for an issue you have 100% of the information about to fix.

    It is as simple as someone internally taking their .bin file (that was stated in ifranky's post that service tested as working) and re-uploading it to the website.

    I don't get how this is a week long thread.




© 2017 Powered by Aspire