The New firmware V03 for Aspire Speeder mod

Aspire Speeder firmware V03 is coming.
here,With the increasing cool features added to the mods nowadays, the combined buttons to navigate the mod becomes inconvenient for users. Aspire’s Speeder new firmware V03 ensure users can experience the new cool features without increasing the trouble of remembering different button combinations. By just holding the fire button and "up" buttons simultaneously users can enter the new menu interface, in which every settings can be reached just by clicking the "up" or "down" buttons.
Under Menu interface,you turn back to the last interface by clicking the "up" and "down" simultaneously.And you can click the fire button and "up"simultaneously back to the working interface.
For more detailed information and download here:
Aspire Speeder firmware V03
  • 25 Comments sorted by Votes Date Added
  • Hi @Tina,

    Thanks for your reply. :)

    Yes, before I upgraded the firmware (and still running V01) I would place the Speeder mod on charge overnight (typically around 7 - 8 hours). The following morning the Speeder would be fully charged and the display would be off (as expected).

    Following the V03 upgrade I've twice found the Speeder to still display flashing battery icons in the morning. What puzzled me is that the Speeder should surely have charged overnight as its had 7 to 8 hours in which to do so.

    Stranger still - since my original post - I've now found my Speeder (running V03 firmware) to once again be be fully charged in the morning and the display switched off as expected(!)

    I live in a rural area (power and comms infrastructure is a little ropey compared to the city) and I'm now wondering if perhaps the mains power has gone off overnight hence the Speeder still charging in the morning and my mistaken belief that it was the Speeder/batteries and or firmware to blame.

    Regardless, all now appears to be ok with the V03 firmware update.

    Thanks again.
  • Worked for me, thanks Aspire !
  • Works here as well.

  • Thanks for the puff counter, Aspire.
  • I really like this new firmware. Has the stuff I could not figure out easily to set and a lot of missing features that just could not be done with the old setup. Great job Aspire.
  • Yes, thanks for this update, makes using the speeder so much easier. "IF" Aspire makes another update, please make the "About" setting that displays the firmware version. I had to hunt about the forum to find out how to display the firmware version since it wasn't in the owners manual.
  • @Cegoca Yes,Your are right.The logo function is not activated on the Speeder mod
  • It sounds wonderful...too bad it doesn’t support my Apple operating system!
  • edited June 2018 Vote Up1Vote Down
    @Tina Nice update except making the puff timer a cumulative number... It would be more useful if it reset each time.
  • @witchcraft the screen of the mod will light up and show flashing battery icons while charging, once the battery is fully charged, the screen of the mod will turn black

    if the screen is still showing flashing battery icons, which means the battery is still under charging

    Please take the mod off the charger and use it first until the battery needs to be charged, then charge the battery again,and to see if the battery can be fully charged

  • @Cegoca Thank you for the feedback
  • How about the same features for the Typhon 100 now ... if it's possible ??
  • @Cegoca You suggestion has been passed to aspire's engineer
  • How is that logo thing used? Thanks
  • edited April 2018 Vote Up0Vote Down
    If I remember well, it is not activated on the Speeder.
  • @Chrjz Once the puffs have reached up to the numbers that users preset, the mod will stop firing, the puff numbers on the screen will flash,please reset the number to continue using the mod or clear up your puff record by using "puff reset";You can clear up the record of use time and puffs by using the "Time reset" or "puff reset",move the cursor to the "puff reset" or "Time reset",then click fire button,then the time and puff records will be cleared up.
  • Just came to say thank you for the v3 update.
    We asked for the puff counter and the timer and got them now.
    Thank you for listening. It's nice to see when a company does that.

    Thumbs up from me!
  • @Focal thank you for all your suggestion.
    Your suggestion always welcome
  • Hi all,

    I've just purchased a Speeder 200W kit and am very pleased with it.
    However, I have a question…

    I purchased brand new batteries to go with the kit.
    The kit came with Firmware V01 installed.

    When charging with V01, once the batteries hit capacity, the mod would shut itself off (this also concurs with what Aspire state about speeder charging:

    However, I've just upgraded to Firmware V03.

    Now, when charging, the batteries continue to flash and the mod does not shut off. I still seem to be reaching maximum battery capacity but it was a bit alarming to plug the Speeder in and awake 8 hours later only to find the speeder not shut off and the display still showing flashing battery icons.

    Is this normal behaviour for V03 Firmware, or do I have some sort of issue with the Speeder and/or batteries?
  • Thank you for the updated information
  • Really like the new Firmware! The Puff counter is just lovely! Would like to say that getting a logo function,if possible,in a future update would be great! Can't complain though the firmware updates have been making an already great mod even better!
  • @Bejeebuss Thank you for the suggestion.
    You are not the first one to give us this suggestion and our engineer had a look at this suggestion and tried to make it, but the memory space of this mod is very limited,there is no more space for the logo function.

  • Hi all, I apologise if the question has been asked/answered before but I was just curious how can I put my Speeder mod in Stealth mode whilst it's locked (to avoid accidental presses). For some reason I cannot put it in Stealth Mode (3x presses) if the mod is Locked (screen off) which I was able to do on my Archon mode.
  • @ MirceaMike We checked with our engineer, speeder mod doesn't have that function, the mod can not go to stealth mode while the mod is locked
    We have passed your suggestion to our products development department

© 2017 Powered by Aspire