Nautilus 2 Airflow Ring

Hello all, i bought Nautilus 2 tank a week ago, and yesterday, i removed the bottom airflow ring for a general clean up of the tank. I dropped it, partially step on it and now while i can put it back, it seems kinda off.

I have some leakage from the side, not the bottom airflow holes.

Where i can find a new one to replace? Local stores in Greece don't seem to have. Not even the retail on line store of Aspire has:

Is there any airflow ring from other tank or even vendor compatible?
  • 7 Comments sorted by Votes Date Added
  • edited September 2017 Vote Up1Vote Down
    A new full base with its airflow ring costs 0,93 €.
    If you are really sure you misformed the ring, because even in its normal state, it is not easy to put back in place.
  • Thanks, i got confused with the site.

    Now about what you said, putting it back. On one side it doesn't seem to fit perfectly with the tank cover above. Like 1mm gap...
  • If you look carefully at the inside of the airflow ring, you will see a difference in an inner ring, almost but not exactly oposite from the airflow opening.
    That part should go over a little notch that you have on the base.
    (sorry, but it is rather difficult to explain ...).

    Do you see that ?

  • Yes, i know what you mean. There is a little "notch" sculpted at the base of the atomizer, and on the inner part of the airflow ring, a sculpted discontinuation.

    I matched those two, but as you said it didn't felt that it came back as it used to be.

    ps* Something weird happened. My mod ran out of battery so i put the Nautilus 2 on a spare vape pen i have for such moments. After i screwed it down, not very tight, it looks like the spacing between the airflow ring and the cover above which screws at the atomizer has equalize all around.

  • So, your problem is solved ?
  • Looks like it, haven't noticed any leakage from the side for the time being.

    I'll have to check it regularly for at least a day.

    I hope it will be fine, else i' ll buy a new base.
  • OK, glad it is solved (for the moment ?) !
© 2017 Powered by Aspire