Archon + Clieto 120 coil ohms issue

Hi folks, i have the above setup using the 0.16 (100-120w)

The problem i am having is, when i put in the coils they start off at about 0.18ohms but then after a short while the ohms rise
highest has been to 0.48, obviously the vape is different too, not as good, i am using homemade juice with 0 nic. 60vg 40pg

Any thoughts on the ohms issue please?


  • 19 Comments sorted by Votes Date Added
  • Sorry I could not help any further.
    I have two Archons and both have a very accurate resistance reading compared to my resistance checker tool.
  • I took it to the shop i bought it from, they just thought the tank was on its way out (the pin)
    So, when i got back home i was about to order another when i had the idea to rough up the pin
    so i used a bit of sand paper on it and tried it, straight away it went in at 0.16 (not seen for a good while now)
    and its stayed at 0.16 ever since.

    Again, thanks for the advice :)
  • edited September 2017 Vote Up0Vote Down
    Probably a defect batch, have you tried with others ?
    What about on another mod, does it react the same ?
  • Hi, thanks for the reply, that was my thoughts too, they were all from the same box of 5,but I think only 2 of them did it. I do not have another mod capable, I am about to try a new coil from a new batch later on......
  • \Hi again, just put in a brand new different batch authentic (just checked) and its a 0.22 not the 0.16 as quoted..
  • edited September 2017 Vote Up0Vote Down
    Do you prime the coil well before the first use ?
    What is your Archon's firmware version ?
    Have you already tried to update it ?
  • HI, by prime you mean put juice on it, if so then yes, i soak it well

    I am using the FW version where you can use the puff counter, but having just looked on the FW page, its saying you can go up to 999999, i cant on mine its only 999 so im not sure its v7, that answers the last 2 lol

    PS the ohms have started climbing again, its annoying, i have to loosen the tank, blow in the air holes to cool it then tighten.... crazy, do ya think i should retry v7?
  • To know your FW version, remove one battery from the Archon and put it back while pressing fire ... what do you see on the screen ?
  • Sorry for the late reply, it was V7, i have tried V6 and V2 and all three do it.
    I am at a loss now as to what the cause is, could it be the Archon breaking down?

    It does not appear to be doing it in Ni mode with my Crown and a Ni200 coil
    just in wattage mode with the Cleito 120 (fat boy glass)
  • Have you cleaned the 510 connexion ?
    Tried with another ato than your Cleito 120 in power mode ?
  • HI, i normally do a clean when i change coils, this time i didnt because it was a very short period between
    coil change trying to figure out whats going on, hindsight i should have cleaned the 510, 20 mins ago after
    reading your reply i did clean both male and female and since then the ohms have stayed at 0.23, hope im
    not tempting fate but it looks like that could have been the issue, rookie mistake :/ thanks for your help, hopefully i wont need you again, thanks ever so much :)
  • Dammit, spoke too soon.....
  • What about my second question ?
  • Sorry, I do not have anything else, prior to this aspire setup i was on kbox mini with a crown on Ni200
    Before the crown it was the standard kangertech tank that came with the kbox mini, again running Ni200
    I tend to get stuck with one, if it works, why change it, only been on vape for 2 years now
  • Any BM shop nearby where you could make some tests ?
  • Looks like thats my last option, i will nip in this week, thanks again for your help
  • edited September 2017 Vote Up0Vote Down
    So, the issue was the Cleito's contact pin, not the Archon ?
  • Well, good to know and most of all, glad your problem is solved ;)
© 2017 Powered by Aspire