NX75 firmware issues

I've been having trouble where whenever I charge up my Aspire, the readout show 0 ohms and I have to remove the battery and put it back in so the thing will work. The vape shop told me to download the latest firmware. I plug the device into my PC, and download V7. It wants a rar file opener (never heard of rar files before). I've tried several from the windows store but I get errors, and also see no way to get the firmware to my Aspire. It's plugged into my WIndows 10 USB, When i look in my drives, there is nothing showing the Aspire. I've tried multiple USB ports.

Unrelated, my readout keeps asking me "new coil?" sometimes even after I recently put in a new one. Is this a glitch, or?

  • 1 Comment sorted by Votes Date Added
  • edited August 2017 Vote Up0Vote Down
    @vlawde Get 7- zip (it's free) to extract your rar file, in a specific directory you have chosen.
    You will have two files now, an executable (aspire-update.exe) and the firmware file (nx75-v07.bin).
    Run the exe file (a window will open) and connect your nx75 to your pc with the usb cable (the one you got with the nx will do), the window will display the current fw version of your nx and will want you to browse for the new fw file, then select "update" ... it will take a few seconds to be done.
    You have upgraded your nx75 :D
© 2017 Powered by Aspire