Aspire Plato Won't Work. Firmware Issue?

Hey guys, so I bought a Plato in July and had it a little over a month. I used it enough to recharge the battery around 5 times. I used it one night and it was working fine and I turned it off. I woke up the next morning and it turned on for a few seconds and then the screen went black so I tried turning it back on and pixels on the screen lit up dimly and flickered. I tried a brand new battery with no luck. I then thought it might be the firmware so I was going to try to update it, but it wouldn't even connect to my compter. I tried returning it to the store and lucky me, there was only a month warranty so they wouldn't take it back. I just put it up because I didn't vape much but now I want to start back. Is there any possible fix for this? It sucks that I spent $70 to only get to use something a handful of times.
  • 1 Comment sorted by Votes Date Added
  • @IcyBerry

    It almost sounds like the chipset has gone bad. The first thing I would do however is to check that no juice has gotten on the battery contacts. If they are clean and dry you can try to contact Aspire Customer Service, although the unit only comes with a 3 month factory warranty to my knowledge.
© 2017 Powered by Aspire