Aspire pegasus mini showing low resistance

anyone know whats up. i placed my pegasus mini down and when i picked it up again to use nothing happened and the display is just saying low resistance
Comments
  • 5 Comments sorted by Votes Date Added
  • What clearomizer are you using ?
    What coil ?
    Have you tried with another coil ?
  • edited June 2016 Vote Up0Vote Down
    @What clearomizer are you using ?
    What coil ?
    what's more,please make sure you use the coil under correct mode.
    Normal coil under wattage mode,and temperature coil(0.15ohm Ni200)under TC mode
    please try with another new coil and reassemble the 18650 battery to Pegasus mini mod
  • I new at this but it's the standered kit I have not changed anything. I tried it with my partners bowl as she has the same set up and it is saying the same thing but hers works fine with her mod and also it won't turn off
  • @tricky did you mean that :if you use your tank on your friend's mod,the screen shows the same thing?
    but your friend's tank works well on his mod?
    If your answer is yes,we suggest that please change a new coil to have a try,may the old coil is out of live
  • My friends won't work on mine
© 2017 Powered by Aspire