ASPIRE CF SUB charging issue

Hello.I can see device is charging.But the problem is blue led light on device never goes off or turn to green color as described in one of the videos i've encountered with.

I tried many things.I connected cigarette to my computer via USB.I've waited several hours.

I also tried to charge via an adaptor.I tried a small adaptor.I tried a bigger adaptor but results are the same.

Blue LED light doesn't dissapear.

Right now,device is charging with a big adaptor but it has been 4-5 hours.

Small LED light(Orange) in USB cable either does not change color or dissapear.

Is there a problem on device ? Or cable?

Can someone help me please?

Thanks in advance.
  • 1 Comment sorted by Votes Date Added
  • @denizs

    I got this from the Aspire online store regarding the charger you are supposed to use to charge the CF Subohm battery. You can see it here:

    If the capacity of the battery is equal or greater than 2000mAh,we suggest customers to choose specification 2 charger.

    Notice:If customers choose specification 2 charger,when customers want to plug our USB charger to wall adaptor to charge the battery,

    in order to protect the adaptor and get better charging experience,please make sure the output current of the adaptor is greater than 1000mA.

    You need to also make sure that your wall adaptor (if you use one) will be able to handle the current for the specification 2 adaptor.

© 2017 Powered by Aspire