Cleito 5ml Replacement Glass Doesn't Fit

Sorry if this is the wrong place for this but I just registered on these forums right now because I've got a small problem. I purchased a new Aspire Cleito tank & coils along with a larger 5ml replacement tank. Both pieces of glass included with the tank fit perfectly. But the larger 5ml "fatboy" glass will not sit securely over the coils & chimney. It seems like the replacement glass itself is a few millimeters thicker than the standard tank glass, which is why it won't fit. I couldn't find any info about this problem except for a review of the product on another site that said they had the same issue.

So my question is, is there a fix for this other than returning to the shop where I bought it and asking for a replacement?

Also I just tried to scratch off the little thing on the label to check the security code and the whole label tried to come off when I barely scratched it with my fingernail. I carefully scratched the rest off but the last series of numbers came off with a piece of the label, so I can't confirm its legit but I have no reason to believe it's not authentic (other than it not fitting). I have attached a picture of the security label.
image.jpeg
3264 x 2448 - 1M
image.jpeg 1.4M
Comments
  • 1 Comment sorted by Votes Date Added
  • edited May 2016 Vote Up0Vote Down
    @ MotoVape,please send a picture to show your problem to our service :service@aspirecig.com
    she will pass your picture to our engineer.
© 2017 Powered by Aspire