Firmware V05 for Plato

2
Comments
  • @Cegoca Yes I know - but my suggestion WAS to use zip instead of RAR, and not to actually use exe?
  • @woodbar Oops ... now I see what you mean, sorry about my post.
    Good occasion anyway to install 7zip on his computer for the one that hasn't done so yet
    ;)
  • @Cegoca That's OK, I do that as well - speed reading!
  • Greetings everyone. I just got my aspire plato a few weeks ago. I really like this thing!........ Except the damn hoops and obsticles I have to go through to download the updated firmware. I've emailed aspire and they have given me suggestions on what to do. Still no luck. I download the files fine. When I plug the plato into the comupter and click the icon on my desktop, it shows up. When I click open.... that's where the problem is. After that im stuck. Has anyone had this problem? Can someone help me?
  • Try removing the battery cell, plug it in, then put the battery back.
  • @Cegoca I've tried that. When I click the icon on my desktop, it reads my device. Then I have to click "open" to open a file, right? well I click "open" and I don't see any file to open up, or don't know what file to open. This is effing wack! I should just be able to click upgrade or install and bam, done. When i click the "open" button, I guess it's looking for a " .bin" file? I don't know. I'm not stupid, but I'm not very tech savvy right now!! LOL
  • You are nearly there - you have to find a file called

    YJT_50_20160425_havedata_2_language_V05.bin

    when you click on the "OPEN" box and this file is located in the same directory as the original "setup.exe" file was created when you un-rared or unzipped it - the one you used to originally install the Aspire program.

    It is NOT in Program files/Aspireup/ etc. - that is merely the program files for running the Windows side of things.

    IF you can't find it, download the rar package again, just extract the one file as above, and save it somewhere you can find easily!

    Hopefully that makes sense?
  • Hey thanks guys!!! Got it done
  • @Del_Line OK - good news. It's not the simplest of update systems but it gets you there!
  • when will you have mac os software?
  • Ive done this and its killed my plato. All it does now is shows a couple of pixels lit up on the screen but wont work it wont fire or show anything else on the screen
  • Try downgrading it to the firmware you had before.
  • tried and still nothing : (
  • Is your Plato detected by the software when you plug it's usb cable in ?
  • yep all detected it all runs smoothly till the end then the plato turns on with just 2 pixels lit up
  • Bought it in a shop ?
  • im trying to up load it again now, seems to be taking for ever this time round
  • Since updating the firmware my Plato's display turns itself off sometimes and I can't lock it or turn the display back on? I have to remove the battery and refit it ?
  • @Tina Hi Tina! What does your engineer say about the Mac OS update or has he just forgotten it? I'm getting worried. Please keep us informed of this matter.
  • I've just re-read the Plato tips and realised I've been putting my Plato in stealth mode! Quite a good idea to have it, especially at work :-$
  • The update brings more Watt.
    If not what bring me the update itself
  • @dh24580 I quote :
    Firmware V05 for Plato
    The Aspire Plato V05 firmware upgrades step down protection under VV and VW modes. The Plato will detect when the battery charge is too weak to deliver the desired wattage or voltage and will automatically adjust the Plato wattage or voltage to a supportable level. The screen will then show the current wattage or voltage instead of the settings you have set.

    In older firmware versions, the Plato screen did not show the current Wattage or Voltage even when it had dropped.

    Where do you see it brings more Watt ?
  • Many manufacturers such as Joyetech Smocktech bring more Watts in the device through an update. Whether something is at aspire I don't know.
    Write apology with Bing translator as I can speak English if it is not 100 percent lesbahr.

    Greeting
    Thomas

  • Why put more Wattage on a device that reaches the maximum it's coils can handle ?
  • The more Watts the more steam and more taste.
  • How to get the just the update on my Plato.
  • dh24580 said:

    How to get the just the update on my Plato.

    I get it already. Is in the owner's manual
  • Hey guys,

    im new to the aspire plato. bought it yesterday and today i tried to update the firmware to V05 but this isnt working for me. i followed the instructions really, really carefully and now the plato isnt functional anymore.
    After the update the battery logo is on the screen. okay. then i unplug the cable and it is asking me for a new atomizer, i clicked yes, VW mode. then i see 1.0W and cant even change the wattage with +/- buttons.

    what did i miss? tried it several times now. also a downgrade isnt possible anymore. used the equipped usb cable.

    many thanks in advance,
    Marcel

    EDIT: When i choose temp mode i got 0° and when i click it shows me 100°C or 212°F. i cant change the temprature too.
    reinstalled the drivers. reinstalled the setup.
  • @franz-josef

    Try one of the previous firmware upgrades for this model. I suggest v03 that you can get here: https://www.aspirecig.com/upgrade/plato/330.html
    then v04 here: https://www.aspirecig.com/upgrade/plato/329.html
    Also, did you check the scratch off to make sure it's authentic?
© 2017 Powered by Aspire