Firmware V05 for Plato

The Aspire Plato V05 firmware upgrades step down protection under VV and VW modes. The Plato will detect when the battery charge is too weak to deliver the desired wattage or voltage and will automatically adjust the Plato wattage or voltage to a supportable level. The screen will then show the current wattage or voltage instead of the settings you have set.
In older firmware versions, the Plato screen did not show the current Wattage or Voltage even when it had dropped.
Click this link to download this
  • 70 Comments sorted by Votes Date Added
  • Updated both of my Platos - only differences I have noted so far (I am low wattage MTL VW user) is:

    1) When I fit a new battery it asks me "New Atomiser?" - if I answer NO (default choice) it just carries on in the same mode as before you took the battery out. Good feature for me, I now don't have to answer all the setup questions regarding VV/VW/TC etc. ?

    2) When the battery is getting low it now just keeps vaping as normal - prior to this update I was only really getting half the capacity of my 18650 cells as the vape quality dropped off considerably long before the battery was depleted. Again, a definite improvement to what was my main criticism of the Plato. Battery "sag" also does not seem to be so excessive.

    3) VV mode added.
  • nice update. its great to show what the true wattage is when there is low battery.
  • I waiting MAC OS X Version!!!!
  • What about Linux version ? Never ? :-\"
  • dh24580 said:

    The more Watts the more steam and more taste.

    That might be true for an RDA, but not for a pre-made coil with an indicated wattage rating..some can handle more power, some can't. If you overpower your coil and burn it out, well......... it's hardly worth the extra wattage.
  • @dh24580 there is a manual inside the zip file to tell users how to update plato
  • I just bought my aspire on eBay code comes up authentic. Used it for 1 day trying to update the vape on my pc and it keeps saying uup stops working and now the vape won't even power on. Why? I need help.
  • TssTss
    edited April 2016 Vote Up0Vote Down
    I just got my new Plato and it wont update/Upgrade.
    The program just stops?
    Ive tried to uninstall 10 times but it wont work.

    Windows 7 Ultimate .

    Thanks in advance.


    Finally made it. I had to leave the battery IN when i connected it to the puter. NOT take it out.
  • Still waiting for a Mac OS X version
  • I'm also still waiting for Aspire to deliver a MacOS of their firmware for the Plato.
  • so somthing weird after this update...

    my mod shows 9.99 ohms when the device is not firing, but when i fire it, it will show the true resistance. i tried a battery pull and it still shows that.
  • After update my Plato works normally, but when battery is low its blinking empty battery in screen... This not happen earlier software version...
    Current wattage display not changed when battery is low, allways shows my own settings ??

    Sorry my bad english, google translate this :D
  • This version does not lock coil resistance and is therefore not much use for temperature control. The resistance changes and so does the power with Nickel coils. V03 is still the only version that appears to do this correctly. Will this be fixed?
  • is anyone having their unit power cycle on its own? ive tired 2 different batteries and ive used it, left it alone, then go to try to use my vape only to notice that its asking if i have put in a new atomizer like when you turn you device on or off.
  • Updated successfully. I really hope this update lets me use more than 50 percent of a battery. The sag when firing is tremendous. Other than that I love the Plato and the flavor is great.
  • @vape_man I will pass your suggestion to our products development department.
    Thank you for your kind suggestion
  • Strange, I said nearly the same thing about 10 posts ago? But mine is not a "kind suggestion"?

    As an update, it seems the battery sag is not quite so bad BUT I reckon it STILL only uses about 60% of the battery capacity before it gives up and flashes the empty battery symbol - disappointing.

    Still a nice mod though, just keep a spare battery ready - main downside is being ignored by Aspire "support".

    Just got tempted by an eGrip II - similar idea to the Plato but with a smaller capacity "Cubis" style tank built in using the BF coils + comes with an RBA + can use any exteral tank with an adapter + has a clock on the display. Will see how it compares to the Plato when it arrives.
  • @woodbar
    Now a clock would be a nice addition to the Plato. I wonder if they can do a firmware upgrade to include that? What do you think @Tina?
  • @charlzrocks I will pass your suggestion to our products development department. :D
  • @charlzrocks Possibly a bit doubtful without a hardware upgrade as I think it needs an RTC chip embedded in the design somewhere? For example the Mini VTC 2 has the clock function BUT the original VTC Mini can not be upgraded with the new firmware to provide the clock cos it does not have all the relevant functions in hardware.

    Never mind, I am sure it will make it to the Plato (updated) or Plato V2 very soon!

  • @woodbar

    Well maybe they can incorporate it into a future mod like you suggested. Who knows what they will come out with next?
  • Hi! Any news about the Mac OS firmware for Plato? Hope we'll get it soon. I'm getting sad...
  • @Swedencalling we have passed your suggestion to our products development department,Our engineer is working for the possibility
  • Thanks Tina!
    I believe that I'm not the only one waiting... I do love my Plato but it is annoying to not be able to download the latest updates of the firmware on a Mac. Now I feel more hopeful.
    Greetings from Sweden
  • @Swedencalling It my pleasure to be here
  • I'm trying to install firmware to my Plato via Win 10. When I open Aspire software I can't do anything. Help!?
  • So what actually happens when you run the "setup.exe" file extracted from the downloaded zip file?

    Do you have an "Aspire" icon on your desktop?

    It is not really clear at what stage "I can't do anything" applies?
  • @Tina Where is the 'Aspireup.exe" file located? I couldn't find it anywhere and they will need that to upgrade Plato Firmware.
  • I think we might all be a bit confused here.

    1) Download the rar file for the firmware from this link

    2) Unrar/extract the package and you will find a directory on your disc "Firmware V05 for Plato"

    3) Inside that directory you will find "setup.exe" - double click this file and answer yes to any questions.

    4) You should now find a new icon on your desktop called "Aspire" double click this and voila!

    If you should NOT have the Aspire icon on your desktop then use file manager to navigate to a program called "aspire.exe" which is located in the "C:\Program Files\AspireUp" directory (which was created/installed when you ran "setup.exe") and double click that.

    Let us know when you get that far but it should be pretty easy from that point.

    I am not quite sure WHY Aspire (and others) insist on using rar files as there is very often very little difference in size between compressed/uncompressed and in any case zip files are more common and the unzip function is built into Windows?
  • I believe zip files are preferably used instead of exe files as most antivirus softwares tend to block exe files for security reasons.
© 2017 Powered by Aspire