Pegasus MOD issue

I'm getting a constant battery icon showing on my display. And seems like the mod isn't charging the battery. It is still functional and powers up my tank just fine. I tried taking the battery out for extended period as well as taking out tank and leaving everything apart for a while. I tried different chargers, different batteries.
When I turn the dial I will see the wattage change but the battery icon still covers half the screen. When I try to change the settings of the coil I can see the information displayed for a split second before the battery icon pops over. Like it's all still there but just have this battery icon covering everything.

It's only 3 months old and I've been taking good care of it, watching not to drop it. Not sure what is going on. Is there a way to hard reset it? Is the mod trying to tell me something.

IMG_2747.JPG
640 x 480 - 80K
IMG_2756.JPG
640 x 480 - 75K
Comments
  • 1 Comment sorted by Votes Date Added
  • @tomeroocoo ,i am sorry to hear that.
    This is our first time to meet this kind of problem.
    Please send this pictures and the detailed information to our service:service@aspirecig.com
    she will check with our engineer and try to figure out the problem
© 2017 Powered by Aspire