Plato short circuit problem

Hello people.
My new Plato has a problem that is already reported by many users on the Web: the short circuit protection.
Sometimes, in vW mode, with the MTL hardware, after one or two puff the plato display reports "Short circuit" and power stops. First time it happened i changed the coil, but did not resolve the problem.
I carefully followed the user manual instructions and also the Aspire youtube video that shows how to install new coils.
I noted that a shake resolves the problem for a while.

Any suggestion
  • 17 Comments sorted by Votes Date Added
  • @igipit
    Try reverting back to the V3 firmware and see if that solves the problem. It is listed as an announcement near the top of the forum. Let us know what happens!
  • @igipit ,thank you for your feedback.
    Do your problem solved?
    If not,please feel free to contact with our serivce:
    Tell our service more detailed information,then she will check with our engineer and figure out the problem.
  • Update:
    Now I'm quite sure that the short circuit problem is in fact a thermal problem. If I let the plato cool down for some minutes, all gets right for the first 2 consecutive puff s but the third triggers the "short circuit" protection. Hope this is only a software bug (I'm using the last 0.4 update ) because else it would be a design defect.
  • @igipit
    Try reverting back to the V3 firmware and see if that solves the problem. It is listed as an announcement near the top of the forum. Let us know what happens!

    Well, the "short circuit" problem was the main reason that led me to do the V04 firmware upgrade.

    There are also good news: It is already half an hour I can chain vaping the Plato without problems. I'm keeping fingers crossed!
  • Sorry, you didn't make it clear that you had the problem prior to the update. Anyway....let us know how it goes!
  • Very strange. Yesterday afternon I vaped 6 ml with the plato without getting any single "shor circuit" message. Today I put in a fresh 18650 (my second 2800 mAh Aspire cell)
    and again after a couple of draws the Plato stops and shows the "short circuit" message.

    Now at 11 am, as yesterday morning, the Plato works fine again. May be the plato does not like vaping before 11 am? :))
  • I forgot to say that if i set the power to very low values, say in the range 1-8 W, the "short circuit" message does not appear and this lead me to belive its a circuit problem and non a short circuit one.
  • Even today after 11 a.m. the plato works well without short circuit messages.
  • My plato doesnt even turn on any more. Got a small jolt while vaping. Any suggestions.
  • Its only a month old.
  • help. My platodoesnt turn on. After a small jolt. Any suggestions
  • @glenn

    You have to EMAIL with your problem!
  • I have the same problem. With 0.4 direct-to-lung coil i cant take more than 2-3 puffs and then that short circuit-message appears. And if i go to 42 watts or higer, i cant fire the device at all before short circuit warning. After that short circuit message it works again for couple of puffs if i let the device cool down for few minutes. I think its definitely a temperature problem.
    Problem is same with all firmware versions available on aspire website.
  • Have you tried with another new coil ?
  • Same issue here. I use the Triton Mini and Nautilus 1.8 ohm atomizers, and get about 20 puffs out of them before it begins randomly popping up short circuit messages, or simply failing to fire without any error message. In that case, it emits a light "pop" sound (barely audible) from the atomizer and doesn't continue to fire. It began doing it about two days after I bought it. Tapping it against my hand or shaking it will sometimes get 4-5 seconds of vaping out of it, then it's right back to the errors.
  • What battery cell do you use ?
    Is it correctly charged ?
    At what power do you vape on those coils ?
    Is the arrestor correctly tightened ?

    Otherwise, return it where you bought it, those things can happen !
© 2017 Powered by Aspire