Pegasus won't charge

I have had the Pegasus for about a month now and have been extremely happy with it, until now! It will not charge, I have tryed a new lead new plug and even got a new battery but yet still no luck? Any fixes ?
  • 3 Comments sorted by Votes Date Added
  • @jessie.taylor26
    First, have you checked to see if your Pegasus is genuine Aspire? See this thread:
    If that checks out, then make sure the micro usb port on the Pegasus is clean. Blow out the port real well and try again. You may have a bad battery so that would be the next thing to change. If you bought a weak or inexpensive battery, that could be the culprit!
  • @charlzrocks it is genuine, I have tryed just blowing into the port but still no luck, the battery is brand new efest, nothing seems to be working
  • edited February 2016 Vote Up0Vote Down
    Your problem may be in your USB power source, USB cable, MOD, or battery.

    Don't use a computer USB port to charge your MOD. The MOD may draw more power than it is capable of delivering and damage the computer. I don't charge batteries in my MODs. I use an XTAR charger. My wife does, but uses an Anker® 36W 4-Port USB Wall Charger with PowerIQ™ Technology as her USB power source. We use these to charge all our smartphones, tablets, and e-readers as well. We also use Anker USB cables and battery banks. We have never had charging problems with any of these products. Note that the Anker products we use are over 18 months old and have been superseded.

    E-fest batteries are those that didn't make the cut for one of the big three, Sony, Samsung, or LG. Name brand batteries from one of these manufacturers cost more initially, but will generally save you money in the long run.

    Use a Q-Tip lightly wet with alcohol to clean the contacts on the battery, and the MOD. Also clean the battery cover, and the groove on the MOD. Try charging the battery again. If it still won't charge, carefully clean the USB connector with a thin piece of lint-free cloth and alcohol. Paper towel will break up in the port so stay away from that.

    If your battery still won't charge, use another USB cable, then another USB power source.
© 2017 Powered by Aspire