ACTUAL fix for ASPIRE Pegasus being stuck in Wattage or TC mode.

The Pegasus is my first box mod, and thus far I've loved it. My only complaint is what others have been having issue with: the mod refusing to disengage from TC mode. Others have detailed all manner of 'fixes', and I've tried them all- to no avail. Upon attempting, quite literally, every solution detailed by authors on this forum, I gave in and tried the ASPIRE prescribed solution, and it worked.

As we all know, the issue with the Pegasus is that the software has trouble recogning when a TC coil and a non TC coil are inserted and reinserted. Other posts have instructed users to remove and replace the battery while holding the fire button until the ASPIRE logo fades, to clean the contact points of the mod and the tank with rubbing alcohol (and many more); none of these work, and there's a reason for it: you cannot fool the software with gimics it is unfamiliar with and not programmed to recognize. In order to cycle between TC and Wattage mode, you must do what ASPIRE reccomends.

The Pegasus is designed to alternate between the two modes with a simple function, holding down the fire button for 3-5 seconds. Once a coil of differing mode is inserted and and the fire button held, the mod should make the change. But, as we know, it doesn't always do that.

The only method of changing the modes is to repeat the above instructions. It likely will not work the first time, or even the second, but I assure you it is the only way; repeat until it works. If others claim they have discovered an alternate method, they are likely mistaken and confused the functionality of their process with what ASPIRE suggests (correlation does not indicate causation).

STEPS:
1. Either remove tank and insert tank with new coil, or replace coil in current tank
2. Hold fire button for 3-5 seconds until mod recognizes the change
3. If unsuccessful on first attempt, remove tank, reinsert tank, and repeat process
*When transitioning from a TC coil to a non TC coil, the mod will fire 1-2 times, producing a decent amount of vape, but this is another bug in the software. Be careful with this, as non TC coils are not designed for TC mode and the coils could burn out quickly*

This seems simple, but it's ASPIRE reccomended and, with patience, it works.
charlzrocks
Comments
  • 6 Comments sorted by Votes Date Added
  • Thank you for more insight on this ongoing saga! :-bd
    mrphilosophy
  • @mrphilosophy thank you for you kind suggestion.
    We will pass your suggestion to our products development department.
    In future,we will push them to take user friendly into account.
    mrphilosophy
  • Hi, posting a year and a half later, (April 2017)

    I'm a beginner about to buy some hardware...

    Has this been fixed with The Pegasus or is @mrphilosophy 's fix still needed to make it run?
  • mine is stuck again. this is my second pegasus, got the first one swapped out because it got stuck too. this one is actually stuck in wattage mode. I think going forward im just not going to buy any vapes that don't have firmware posted publicly and non user updatable. its been really interesting with so many people getting in on a blossoming industry, but there is just so much hit or miss with quality control across this entire industry.
  • Hi,

    Sorry to be replying to an old post, but I have experienced this problem too earlier this year, and have just solved it, for myself at least.

    Looking back it all started when I got an urge to go sub ohm, I had been using the Pegasus on and off for a few years, but then at new year I gave up smoking and was using it full time, so as a treat I decided to upgrade to a bigger box mod (SMOK Species), and try to go sub ohm!

    I did not get on with the new setup, too vicious and hot for me as a recent ex smoker, so I tried the new sub ohm tank on the pegasus, that is exactly when the issue started for me!

    So after trying all the online solutions, and also the one above from @mrphilosophy (six times and two burnt out coils), I had given up, and was using my Nautilus X tank on my SMOK box mod, but then the battery compartment on the SMOK box gave way!! ahh! So here I am looking for a solution to that, but on the shelf next to me is my old defunct Pegasus, hmmm!

    After reading all the other ideas, and the one from @mrphilosophy above, I thought what if the software in the device needed to also detect a difference in the resitence of the coil being used? And what sort of variance would trigger it?

    So I swapped the 0.6 Ohm coil to a 1.2 Ohm one and then followed the instructions above from @mrphilosophy:


    And it worked, first time, ok it did burn out that coil, but swapped to Wattage, happy Pegasus vaper again.

    Hope this helps someone.
© 2017 Powered by Aspire