TOO HOT display aspire pegasus

I was ready to move past a tank so I got a simple rda to put on my aspire pegasus box and it worked for a month or two. now every time i press the fire button it will display "too hot" but sometimes it will randomly fire. super frustrated and confused. i have tried everything from getting a new battery to making perfect coils. Now I just wanna know if this can be fixed or if I wasted my money on this vape. thanks in advance for any advice :D
Comments
  • 8 Comments sorted by Votes Date Added
  • edited January 2016 Vote Up1Vote Down
    Could you be more specific about your issue instead of immediately suggesting you wasted money on an Aspire product ?
    What are your battery specifications ?
    What is the battery charge when this happens ?
    What resistance is your coil (and what kind of coil) ?
    What RDA are you using ?
    Do you have the same problem with an clearomizer (like the Triton V2 for example) ?

    Why do I have to ask all these questions ? ...
    watkijw
  • THere are so many factors involved that we would need all the data that @Cegoca asked for to give any type of educated answer. Most folks use RDA's on unregulated mechanical mods and they will heat up pretty much if chain vaped. Also if you are running the RDA on the Pegasus in unregulated mode that will also have an impact. @Cegoca is very knowledgable in this area but needs some data to help ya!
    watkijw
  • ok sorry for the late response and lack of specifications. to answer all your questions @Cegoca @charlzrocks
    1. battery says 18650 2600mAh 7v
    2. the resistance on the coil is 0.33 ohms and it is kanthal
    3. the "too hot" display happens no matter what battery charge
    4. the rda is a sapor with 4 posts
    5. yes i do have the same problem with a clearomizer and any tank i've tried
  • hello AidanVapes ,
    our battery have high temperature protection:If the control board detects a temperature over 65degrees Celsius the mod will cease functioning and display "TOO HOT" for 3 seconds and then enter standby mode,Users may use the Pegasus again once it has cooled
  • Hi

    I'm having the same issue, doesn't matter what I do my pegasus just reads 'too hot'
    I think mine might be the v1 as I don't get the same displays as those shown in the video manual on this site.

    battery says 18650 2500mAh 3.7v
    the resistance on the coil is 0.5 ohms
    the "too hot" display happens no matter what battery charge
    I have two tanks, aspire nautilus (with a 1.5ohm) and kangertech (with a 0.5ohm) and have the same problem. It still shows 'too hot' when I remove the tank and press the button.
  • @ScottShaw Remove and feel the battery. If it's not warm or hot, and the Mod is still under warranty send it to a service center. If the battery is warm or hot, let the MOD cool to room temperature after charging and try again.
  • @Old_Salt Thanks, have tried another battery with still same results. the mod had been sitting overnight in a cool room when it started happening.
  • @ScottShaw
    I agree with @Old_Salt that you should return that mod as defective....could be a bad chip!
© 2017 Powered by Aspire