Aspire Pegasus Mini Stopped Working

Hi, I received an Aspire Quest Mini kit a few days ago and it's been working fine up until now. I was vaping on it when it suddenly stopped firing and the display went off and wouldn't come back on when pressing any button.

I'm using the recommended Aspire 18650 battery in the Pegasus Mini mod. I tried connecting the supplied USB charging cable and the display returned to life and showed the flashing battery charging icon but it quickly stopped flashing as if it had completed the charging process.

When I disconnected the cable and tried pressing the fire button it was unresponsive again with the display staying off. I tried pressing it three times in case the display was switched off but to no avail. I then tried substituting the NI temperature control coil for the 1.8 ohm Clapton coil that came with the kit but the mod still wouldn't come on.

Is this likely to be a battery problem of some sort or something to do with the mod itself?
  • 9 Comments sorted by Votes Date Added
  • My best guess is that you're right, it's the battery. Take the MOD to a local B&M and try another. I recommend the Samsung IMR 18650-25R. If the problem persists with a new battery, the charging circuit in Pegasus mini would be suspect. In that case, you'd need to contact Aspire for further help. I use an external charger (Xtar VP1) for all my batteries.
  • @jfsebastian Was the sliding battery connector (-) still making good contact with the battery? Mine slid off once just from being jostled around, and it worked great again after sliding it back on...

    BTW, I just have to mention - cool name! I love Blade Runner... :)>-
  • So the mod goes "Home again, home again jiggity jig"? :D
  • Shame it didn't have at least a four year lifespan!
  • Shame it didn't have at least a four year lifespan!

    Rutger would be proud!
  • Thanks once again you're a gentleman and a scholar.
  • I took it into a shop and after testing it the guy said it was the mod itself rather than the battery and that it had probably shorted out. He also claimed that this happens to one in ten mods which seems a little excessive. I guess I'll have to send it in. Always nice to meet a fellow BR fan btw.
  • Hahahaha, that is awesome. :)
    And by the way, I would be REALLY surprised if 10% of the Pegasus mini mods went bad. This is the first one I have heard of. Now, if your shop owner is lumping Kanger mods into his stats, maybe... :P

    @jfsebastian too bad you can't engineer mods the same way you make your own friends! ;)
  • I have had 2 Aspire Pegasus mods both broken within a year each with exactly same problem. The sliding battery connector has come off and both shops I’ve been too say it’s unfixable. Is there a way to open and repair? It’s almost as if the rod holding the slider has slipped too deep into the unit . Please help, once I can accept but twice; come on!!!
© 2017 Powered by Aspire