Pegasus Ohms Jumping Around

Hi all,

My Pegasus just arrived in the post this morning. I fitted it with a brand new Nitecore 2000mAh 18650 flat-top battery then charged it so the battery is full.
I'm using a Cartel Cascata RDA which is absolutely fine on other devices.

The Pegasus ohms are jumping around quite a bit. And when fired, the battery drops considerably (on the display). I'm not even sure if this is safe.
I built another coil for this RDA just in case. No difference. I tried the solutions at the top of the page too. No difference. It's kanthal wire.

I've also tried with a brand new LG 18650 2500mAh battery. Same thing happens.

I've posted a (rubbish) video to YouTube to explain what I'm on about, which can be found here:

My face isn't much to look at, but I'd like to keep it in one piece. Is this safe? Should I be doing something differently?
I had a similar issue with an MVP 3.0, but that developed over months and I eventually just wrote it off.

I love the look and feel of this mod. I don't want to have to send it back.

Thanks.
Comments
  • 5 Comments sorted by Votes Date Added
  • @KarachiKid the voltage will drop under load so its not entirely surprising the display changes - both of my Pegasus mods do the same and I have two friends who have a Pegasus and theirs do the same with the battery. I'm pretty certain there's nothing to worry about there :)

    @Old_Salt while I agree with the resistance changing with temperature, there isn't any predictability when I've observed the phenomena that @KarachiKid also shows in the video - its up and down seemingly on every press of the fire button. If this effect was entirely due to temperature change, there should be at least some predictability in the changes observed in the resistance displayed but that doesn't appear to be the case.
    Regardless of the cause, I don't think there's anything to worry about in terms of safety :)
    KarachiKidOld_Salt
  • I have 2 Pegasus mods and they both do the same. You are only observing a jump of a couple of hundredths of an ohm.

    I currently have a dual Clapton (using Kanthal) running at 70w and the resistance jumps around between 0.35 and 0.37 ohms on the current one. Your video shows the same kind of jump between 0.71 and 0.73. This doesn't seem a large enough difference to be of concern. I've just tested the same RDA setup on my MVP 3 Pro and that shows a resistance of 0.39 but that did change to 0.38 a couple of times but was generally more solid.

    I guess its just a limitation (or quirk?) of the chip in the Pegasus (that seems to change resistance read every time the fire button is pushed) - but I don't think you will have any safety problems. I've observed the same phenomena you describe and I've had no safety issues.
    KarachiKid
  • Don't forget that the resistance will change when the coil heats up. For Kanthal heated 250°C that change is 0.04Ω. A difference or jump in your reading is to be expected.
    KarachiKid
  • I do not have a Pegasus but a lot of mods tend to have battery drops when firing. It is due to the fact that the Voltage supplied is dropped because of the atomizer taking the load. If you put a 510 inline battery volt meter on it you would see the battery at current resting state and when fired the voltage read out would show lower as you fire the device and return to its current battery voltage after you quit firing the device.
    Viruk
  • Hi Viruk,

    That's reassuring. Thank you. The MVP was completely gone though. It was jumping from 1.5ohms sometimes over 4. It was a problem a lot of people had with dodgy wiring. Regarding the battery meter dropping when the button is pressed, is that normal? It's an odd feature if it is.
© 2017 Powered by Aspire