Possilbe Flaw

Been doing some reasearch on my Pegasus mod with Temp Control, Ive noticed when i attached a new Attomizer it DOESNT give give me the option saying NEW ATTOMIZER ATTACHED. Regardless wheather or not it Kanthal or the Ni200 coil in my Triton. or using kanger tank, rda or any attomizer. Not sure if its a earlier version on the chipset, the type of coils im using or what. Ive been watchibg some clips on good Ole Youtube with people who have the pegasus, admittedly they using clapton coils, and their pegasus give them the option most of the time. So wheather thats got something to do with it or not, im stumped. If someone with knowledge on this matter can help please comment.
Thanks
Comments
  • 20 Comments sorted by Votes Date Added
  • I think most of the issues with the V1 were with folks that switched between the 1.8Ω Kanthal coil, and stainless steel or nickle coils. Perhaps a resistance check, before the auto detect, and going straight to wattage mode if the threshold were exceeded would have been a better approach. It would be really nice to see update-able firmware in Aspire's next MOD. There will always be something that could be done better with a new MOD on the market. Firmware updates would keep the complaints down to a dull roar.
    watkijw
  • Old_Salt said:

    There will always be something that could be done better with a new MOD on the market. Firmware updates would keep the complaints down to a dull roar.

    Now I must agree. A reachable menu (with 3 clicks for example) would be nice(r) too.
    Without going to the other extreme like with the DNA200 chipset, where you must change parameters through a pc software ...

    watkijw
  • If you still can, please include Pegasus in the title. It makes things easier for all.
  • @Old_Salt I am not able to edit the Subject line using my phone, will try later when I get in using the laptop
  • @"Vapers and Flavors" I believe the Pegaus will only give that menu option when you are in TC mode. There is no need for it in VW mode.
  • @Vapers and Flavors Try this.....remove the Tank from the unit and press the fire button....it should say check atomizer...then replace the tank and it should ask if it's a new one. Let us know how it goes.
  • @charlzrocks

    Tried that didnt do it, but for some strange reason it went into Temp control mode with a 0.4ohm none Tc coil.weird...
  • @watkijw ok thanks for that will try the Ni coil in it, detached it. Then press botton so it say check attomizer. And report back soon once little ones are in bed..
  • Update: I have refitted the NI200 TC Coil, put the Triton back on the MOD, Pressed the fire botton for the MOD to reconize the coil,
    took it off again, pressed button so it says check attomizer and reayyached the triton. Still doesnt come up with the Option.

    Reattached the OCC 0.4ohm, that didnt didnt come up the option either,
    NOT Tried the TI Coil simply for the fact I dont have one to try

    I went into the E-CIGWIZARD shop today about this issue, and was told it wouldnt come up with it, because of the chipset it has. The pegasus will automaticly see what coil it is once i pressed the botton for the relivant time of 3seconds.( So why do some of the Pegasus TC Mods do the option but others dont ) ?? He couldnt answar that. Not sure what to think of that one. I would have thought that the REPS of these E-Cig Shops are supposed to be on the up with all the knowledge with every MOD, TANK, Coils etc etc sold. Not sure if this bloke knew his rear end from his elbow,
    or he generally didnt know about it .

    I'm not overly fussed, The Pegasus WORKs It reconizers the coils etc .
    but after seeing some of the pegasus giving the options and some dont, Yet they are all TC MODS. Confusing.com

    Hopfully a ADMIN of Aspire will read this and be able to answar the Possible FLAW ??
    ADMIN
  • edited November 2015 Vote Up0Vote Down
    @Vapers and Flavors You must know (and also the shop holder) there are TWO versions of the Pegasus.
    V1 : automatic after 3-4 seconds
    V2 : with menu choices.

    I suppose you have V1 ?
  • I was totally unaware there were two versions, so I must have the V1 press for 3seconds.
    But as for the shop not knowing, who they are suppose to be selling Vaping products, supposed to know what they selling, isnt a very good example to give us general public to the answar (I Dunno know) Well i wont be going buying any more products from them again..besides my 70/30 mix.lol..
    Well I have learnt something new yet again..

    Thank you for the information on this matter. At least now I shall be able to sleep better knowing my Pegasus isnt defective after all
  • @Vapers and Flavors Should the coil not be detected correctly, try removing the battery and put it back.
    Sometimes, it's also a sign the battery should be recharged or changed.

    I suppose the shops can't know everything about all products on the market ... ;)
  • I have noticed somewhat strange thing is using a 0.4ohm coil for some strange reason, every so often the pegasus seems to go into temp control mode. I have to change the attomizer to my rda or a kanthal coil to change back to wattage mode. Then go back to my triton. So far only seems to do it on a fully charged battery. Odd very odd
  • Perhaps because those coils are made of SS 316L, coils that could possibly also be used in certain TC devices ... I will give it a try some day >:)
  • Ah yes, I had assumed you were talking about the Pegasus v2. It is clear that you have the v1 after all. The shop owner probably should have known about that, but what can you do?

    I have both versions, and haven't had any issues with either. Just be careful when switching back and forth between TC and VW modes.

    Good luck! :D
  • @watkijw Its not as Iam having issues switching over from Temp contol to Watts or vice versa,
    I just assumed all TC pegasus's models had the same chipset, and have had the same menu system, clearly I was very wrong
    My pegasus seems to work fine, just has a differant way of switching over to some out there.

    above all I love my little beast, MUCH, MUCH , Much better than the Kangertech Nano I have,
  • Yeah, all the Aspire gear is miles ahead of Kanger in my opinion. The two Pegasus models have the same chipset, but the menu system was converted to manual for the v2 because so many people asked for it. I love both my Pegasus models, and use them regularly. Honestly, I wouldn't feel too bad about having the v1. :)
  • @watkijw I have to say even though it has the V1 chipset I love it regardless, I use it alot more than my kanger Nano now which is just sitting on the shelf next to my collection of tanks, RDA and othe attomizers
  • @"Vapers and Flavors" I assume you mean the Subox Nano. That thing just looked cheap to me, so I never wanted one. It looks like if you dropped the mod, it would smash to pieces. The Pegasus looks like you could use it as a hammer... LOL (not recommended, of course) ;)

    I do fully agree with @Old_Salt and @Cegoca that the next mod should have upgradable firmware. I would think Aspire learned from the Pegasus, and this is already in development. They really seem to listen to feedback and make changes, even if it is not always directly communicated with the public. :-\"
  • @watkijw
    Well at the time i was looking to upgrade from the old cheap ecigs
    I didnt have enough funds on my at the time, so the subox nano was the only option at the time. Wow that thing is thirsty on power. My 18650 2200maH 20a would last halve a day from fully charged if i was lucky. I wasnt even on it every second even, the battery was pants. I was using something a 1.8 i think on it.
    If i used a 0.5 on it well goodby battery in 2-3 hours running at 20-25watt.
    But yet if I put my plume veil on it, it was abit better.
    But with this pegasus odyssey kit, i brought it off fleabay, came with the triton of course, a iclear30s tank, 3 Batteries and a efest single battery charger for a mear £62 with postage.
    Still had oridginal box, lead, manual etc. Previous owner couldnt get on with it. So I grabbed it while i was a little flush with extra funds. Never regretted it. Had a little issue with the postage my end, as the sender wrote my address on it incorrectly. But lucky enough where it was delivered to was only in the next village to me. Phew

    With that said thats what i love about Aspire they do seem to listen to their customers views and comments.
    Be great if they made these pegasus mod firmware upgrable aswell, or a way of tweeking the display allowing the user to place a welcome message, edit the txt font styles. Sounds mad i know. But it a customization touch would go along way aswell. With having a simple user interface, not dissrupting any vital features.
    Just a thought.
    ASPIRE what do you think..
© 2017 Powered by Aspire