Triton 2 - drip tip system almost impossible to remove

I just bought the Triton 2 tank, and I'm already having problems.

The clapton coil works really well, and there's no leaking anywhere but unscrewing the Triton 2's drip tip system is a serious PITA and took me about 5 minutes for it to budge using my hand. Once the tank was filled, another 5 minutes to replace. It's super hard to try and catch the threads, and even after it does, I can't tighten it down fully by hand. It's supposed to sit flush, but there's about another half a turn that it needs to go, but won't.

I've now refilled the tank for the third time, and it's not loosening up at all to remove or replace. My thumb is bruised. Is this a dud, and should be replaced? The tank's only 2 days old?
  • 65 Comments sorted by Votes Date Added
  • Problem solved folks. I went back to the store and the drip tip system wouldn't sit flush on another tank, so it was promptly swapped out by the store. Works perfectly, my thumbs thank them, and you guys.
  • AWESOME!! Glad to hear it! :-bd
  • This is indeed exactly what I did. :)
    Thanks for your images.
    Awaiting your findings after a few tanks.
  • Just to clarify, when my tank did leak it was out the bottom AFC, and not the top. Something must have gone wrong with the bottom seal, but I can't recreate the scenario.

    I'm sure others are having small difficulty with the top cap on the v2 as well, but just muscling through it like I was at first. I think this really is a nice fix to prevent cross-threading, and just making it easier all around. :)
  • Thanks to this thread I can now screw the top on the tank smoothly. The solution works great! Thanks for everyone for coming up and testing this solution.
  • And there we have it gents. The simple fix, pretty much staring at us all along. Pliers back in the toolboxes, and handkerchiefs only being used on noses.
  • I personally like Aspire's original Triton with a 1.8Ω coil. It delivers good flavour. There will probably be those who'll scream 'NO! don't go there!' Some folks have reported that they leak like sieves. I have six of them. Two came directly from Aspire, four 'leaky' tanks were acquired locally. The most I paid for the 'leaky' tanks was $5.00, and two were free. Three of them worked perfectly (no leaks) after a cleaning and replacement of the coil. The last needed a new seal at the top of the chimney. An alternate, if you don't want to go there, is Aspire's Atlantis. Get the 510 drip tip adapter, and a drip tip with this tank for mouth to lung vaping. These tanks can use all of Aspire's coils for the Atlantis or Triton series. The new 0.5Ω Clapton coil is very good.

    If you decide on a used Triton original, check the security code before you buy. If it was checked more than about five times, it's probably one of the many cloned on the market.
  • @Cegoca I found this interesting, so I decided to give it a shot. You can see here how the gasket is shipped:

    And here, I believe, is your fix:

    After trying this, it is indeed much easier to thread the top cap! This could really help avoid any cross-threading. Here is one more view after installing the top cap:

    You can see that the o-ring does not form a very tight seal with the chimney, but honestly this might be a worthwhile tradeoff. I am gonna vape on this for a few days and see if there are any leaking issues. Thanks for the idea!
    3264 x 2448 - 1016K
    3264 x 2448 - 880K
    3264 x 2448 - 937K
    Before.jpg 1015.7K
    After.jpg 879.9K
    Installed.jpg 936.7K
  • @Cegoca Go right ahead! They are just pics taken on my iPhone, and I don't care how they get distributed. :)

    For some reason, they did all get turned 90 degrees counter-clockwise when I sent them to myself, so you might want to fix that before you repost them. LOL
  • edited November 2015 Vote Up1Vote Down
    Thanks for that prompt reply @Cegoca. I'll go steal borrow from the wife.
  • @charlzrocks More than just a try, as it works for me without any problem so far.
  • The fix is simple: apply some vaseline in the drip top cap o ring and screw threads and you're ready!
  • @watkijw Thanks for the illustration. I removed the o-ring from the top channel and placed it down into the second channel and it works like a charm. The tool of choice was a micro screwdriver.
  • @big_vape Did you check the scratch off to make sure it is genuine Aspire? If the top is threaded correctly, it should sit flush when hand tightened. I just checked mine and it is pretty tight to unscrew as well due to the double o-rings on the top. I used a dab of eliquid on the orings and it glides on nicely...tight but it seats all the way. Yours may be cross threaded or is a fake with bad threading. This is the first I have heard of the top not going on all the way. Get with your retailer and ask for an exchange. If you bought it from the Aspire website contact them via the after-sales service center listed as a sticky at the top of the forum. If you are that unsatisfied with the tank, I suggest you return it to the retailer where you got it for an exchange.
  • @charlzrocks, thanks for the reply. Yes, it is an authentic product. When I first opened the packaging, it took nearly 5 minutes to unscrew the drip tip system, and it was sitting flush. I will attempt once again, while trying some eliquid on the o-rings. I doubt I could cross thread only using my bare hand. I will ask for an exchange, and make sure while i'm in store it actually goes back on completely. I'd hate to go to a different tank as this is the best I've ever used. I notice the original Triton was not threaded. In your opinion, is it as good a tank as this V2? I've read all the complaints on the original, but if I'm certain to use it in vape mode, should i have any leaking?
  • For me, the V2 is an improvement compared to the V1, although I also admit it can be quite difficult sometimes to unscrew the drip tip part (I use my handkerchief).
  • Thanks for the comments gents. Here's a thought, what if I were to remove one or both of the o-rings to get this flush. Would you suggest the top closest to the drip tip, or the one closer to the tank, or neither. I'm really loving this tank, but my god, my thumb is close to bruised.
  • I can't recommend that either of the o-rings on the heat sink be removed. The inner o-ring seals the against the chimney, preventing leaks along the chimney through the drip tip. The outer one prevents leaks to the outside from the filling chamber. The o-ring on the drip tip holds it in place and doesn't affect heat sink removal.

  • Here's an update. 2 tanks, top drip tip system sits flush on both. Can I remove the drip tip system to refill without destroying my thumbs, a resounding NO. One can only surmise, this was done by design.

    Now to go find my pliers.
  • No pliers needed ...

  • I actually tried using the handkerchief to no avail. Still haven't used the pliers, but if I do, I think I'll wrap the handkerchief around the drip tip system before giving it a good yank.

    What a great design. There's no way this baby's gonna leak.
  • I am surprised - I find the top section firm, but definitely able to turn. I think I had more trouble getting it to the fill position than unscrewing the top cap.

    I'm not trying to be a smart aleck, but I have to ask. Are you sure you are not over-tightening the cap? And have you tried a couple drops of juice over the o-rings? And also sure you did not cross-thread the cap? Just trying to help problem solve.
  • edited November 2015 Vote Up0Vote Down
    See the other post, I hope for a solution.

    Copy-paste ...

    I have removed the inner o-ring and put it just up "one floor" (couldn't actually put it back on its original place after 5min. trying, so think about it).
    Doesn't seem to change anything on the vape quality and on its sealing.
    To be continued ...
  • Emptied two tanks with the moved o-ring ... no problems ... top cap screws and unscrews very easily and is now nicely flush.
    Just be careful that it doesn't leave its (new) place when removing the cap.
  • @Cegoca Can you put up an image of where the o-ring is? Is it the one on the outside or inside of the heat sink? The outer one on mine is in a groove just below the threads.
  • @Old_Salt Sorry but I can't post an image right now.
    It's the one inside, that is supposed to match round the chimney that comes out between the filling holes. Hope this is clear to you, not easy to explain ...
    You have the same problem ?
    With the change I made, I must admit there is a bit more condensation coming into the filling chamber, but not bothering to me.
  • I'd really wish for Aspire to comment. Perhaps one floor up is where it was always meant to be, but these first runs were done incorrectly and not caught. The tank is really great otherwise. @Cegoca I'm not aware of your other post where you first did this, so please keep this one updated.

    Thanks kindly, and hoping for a permanent solution.
  • it was your double post on the "Triton 2" thread I meant.
    Let us indeed keep it easier staying here about that problem :)
  • Thank you. I don't know why, but I was stuck on the outer o-ring. :-t
© 2017 Powered by Aspire