Triton suddenly stopped working - help!

Hello everyone!
My name is Teenie and I'm quite new to the vaping world (about 2 months)
My brother got me a triton tank to use and I have been relatively happy with it and I have been keeping up with its maintenance as far as changing coils, cleaning etc..
Last night it just...stopped working.
It wouldn't work on either of my batteries and I tried it on my brothers Sigelei battery (I have used it before with my tank) and it would no longer recognize that a tank was even on it!
It just kept saying the "check automizer" message - like it does if you press the button when there is no tank attached.
Has anyone run into this problem with the triton or other tanks before? Because I'm so new, this is the first major problem I've ever encountered and I don't have to money to just go buy a new tank - is there a part I need to replace or something?

Thank you all for your time and assistance in advance!

-Teenie
Comments
  • 2 Comments sorted by Votes Date Added
  • Hi Teenie,

    "Check atomizer" usually means that there is no path for the electricity to flow through the tank. It could be that the coil is not making proper contact with the base of your Triton, or that your coil is burned out like a light bulb. Take the base off of your Triton and clean it well. Clean the threads of coil, and the pin at the bottom. Screw the coil firmly into the base of the Triton. Before you put the base of the Triton on your MOD, turn the power of the MOD to its lowest level. Put the base of the Triton, with the coil on your MOD, and try to fire it. If it still says "check atomizer" put a new coil in the base of the Triton and try again. If it still doesn't work, try tightening the base a little more onto your MOD. If your MOD had an adjustable center pin on the 510 connector, turn it it out a full turn. Try it one more time.

    If that doesn't work, the rubber insulator in the base of the Triton may have expanded, and you'll need a new one. It comes with the connector pin as part number 3 in the Aspire on-line store under "Aspire Triton accessories." You may be able to get the Triton to work for you while you wait. Use a small screwdriver and press the connector pin firmly into the base from the bottom. Try it with your MOD again.

    If it still does not work, push the connector pin and insulator ring out of the base from the top. Put the connector pin into the insulator ring upside down and gently rub it against some fine sandpaper to remove a little of the rubber. Clean the parts, Press them back into the base, and try again. Repeat if needed.

    Hope this works for you :)
  • Good info couldn't have said it better myself.
© 2017 Powered by Aspire