Aspire Pegasus stuck on Temp Control

I used the 0.4 ohm coil that the triton came with and had a wonderful experience up until now. Somehow the mod switched to temperature control without my doing. Now I can't get it back to wattage mode because this type of coil I cannot use with the temperature control system. So I have tried almost everything and I am wondering if it's the mod and if I should return it for a new one. When I take the battery out then put it back in usually the aspire logo shows then it goes blank well my mod goes straight to the temp control screen where it shows the temperature voltage resistance it doesn't blank first. So is there a way to get it to wattage mode?
  • 9 Comments sorted by Votes Date Added
  • Did you try removing the tank before resetting your pegasus? Remove the tank, then remove the battery for a couple minutes. Put the battery back in and push the button to restart the mod. Add the tank on last.
  • I would have agree with watkijw give that a try and let us know.
  • Yes it did work! I wasn't holding the power button long enough to switch back to wattage mode I think. I was afraid of firing the coil on temp control mode since the stainless coils are not to be used on temp control.
    Thanks guys,
  • Any other ideas? same thing happened to me 30 minutes ago, and the above doesn't work. Stuck in TC and can't use the mod now.
  • Took the Pegasus to my vape store. They had the same issue with it, until they swapped out the Triton tank for a Kanger SubTank Mini. Came right off TC and has been fine since. Don't know why both my Tritons with 1.8ohm coils failed to take it out of TC mode, plus the Triton they tried in the store, but the Kanger did. However it's fixed now.

    Kind of a nasty little firmware bug though.
  • Had the exact same issue with my wife's Pegasus MOD w/ Triton tank. Tried everything (including the above) and nothing worked. Finally, I took a cotton swab (with a little alcohol) and cleaned the bottom contact surface of the tank, and the tank contact on the top of the MOD.. I figured if their both electrical contact points, then they may suffer from the same issue that any other electrical contact point suffers... oxidation!

    THAT DID THE TRICK!! I put the tank back on, pressed the button for 3 seconds... and BAM. It switched from temp control to wattage. Problem was fixed (for me at least). Hope this helps someone.
  • Cleaned it, 4 tanks loaded one with a 2 ohm kanthal, install battery quick pressed for 3 second, tried numerous different batteries that worked before and nothing works as it is still stuck in temp mode and sometime fires at what feels like 70 watts and sometimes will not fire at all. Defective piece of garbage that tries to be so smart it is stupid. How to manual switch to wattage mode?????? All the above are hit and miss and are not repeatable solutions.
  • I got mine to finally work today by adding tinfoil to my tank so it could reach the connection. It was working fine for about a few hours and now it always starts in tc mode and if I reset it it switches over to tc mode after pressing the fire button once and always says check atomizer. Any ideas? This is the first mod I've ever owned and so far it's been so terrible that I'm thinking about just going back to pens.
  • @jmfalk

    Sounds like your 510 pin is stuck down. It's spring loaded, so clean the area well with alcohol using a q-top to loosen the pin for it to contact your tank base.
© 2017 Powered by Aspire