Pegasus temperature control

Hi all

Had the Odessesy kit for just over a week now and I'm really happy with it. I've been using the 0.4 coil at around 30-35 watts and getting in with it great. Lovely flavour, clouds etc.

Last night I decided to give the TC coil a go. I set it up normally as per the instructions, turned the mod on and held the fire button for 3 seconds. Nothing happens. The mod simply reads the wattage and the Ohm which is between 0.15 - 0.19.

Now am I missing something here or should the mod be switching to TC mode and allowed me to control the temperature. From the little information I can glean online that's what it should do?

Either way it doesn't taste quiet right and is not producing much vapour. I've checked the tank is set to Vape etc so I'm really not sure what I'm doing wrong. Any help would be appreciated.
Comments
  • 17 Comments sorted by Votes Date Added
  • Mod didn't work at all. No clouds, just small
    Amout of vapor- less than a cigarette.
    temp control not working at all.
    Tried all three coils that came with kit.
    Had fully charged battery. Very disappointed.
    Sent kit back for replacement. Am I the only one who got a defective kit.... New to box mods, tried everything.Watched all videos. Hope they fix or
    Replace : (
    Philip021
  • @Philip021 Not sure which part of the world you are in but in the UK you legally do not have to have the receipt to prove you bought something from a retailer as long as you can show them a statement of your account, either debit or credit card, showing a suitable amount was paid to them on the relevant date they are obliged to accept that as proof of purchase.

    Not much help if you paid cash of course!
    Philip021
  • edited September 2015 Vote Up1Vote Down
    @Philip021 if you are a customer in USA,please pay attention to our after-sale service center in USA;https://uvaper.com/return_form_download
    Philip021
  • See what I mean, some (a few) get a reply from support whereas a lot (including me) get totally ignored.

    Perhaps any new prospective purchasers should take note - if you have a problem with your purchase you WILL get help and suggestions from forum members but you only MIGHT get help or support from Aspire.

    Be warned.
    Philip021
  • Hi, the only thing that springs to mind is that they updated the 3 second instruction to 4 seconds and I read somewhere that if your battery is a bit low on charge it may take "a little longer to detect the TC coil"?

    You could try removing the battery, to try and reset the device, then install a freshly charged battery just to see if it makes any difference.

    I know a few people have had problems getting it to switch into TC mode - you could have a read through this other post for details -

    https://forums.aspirecig.com/discussion/27062/first-impression-of-the-pegasus#latest

    it might give you some ideas.
  • Taking the battery and replacing seems to have done the trick. Must say the vapour does seem a little harsher in TC mode but not bad. Will give it the day and see how I get on.

    Thanks for the help
  • @Sherryremy I am sorry to hear of the defective unit. Perhaps the replacement will change your opinion! Remember that there are different coils in the kit and the way you vape makes a difference too. Do you do mouth to lung or direct to lung vaping?
  • @Sherryremy Similar issues with mine. I bought the Odyssey kit less than two weeks ago from my local shop, upgrading from my Aspire 30W box. The first week I was pretty much in denial about its performance, trying the different coils, airflow configurations, and a higher discharge battery. Finally today I threw the Triton tank on my 30W mod. The beat up old box thoroughly outperformed its intended replacement.
    I went back to the shop today and they confirmed it wasn't the battery or the tank, insightfully offering that maybe it's a "bad chip."
    Still had the box... but no receipt, so they wouldn't replace it.
    Aspire, are you out there? Make it right! D:
  • @woodbar That's a nice take on things, guess US shops have more discretion. This shop's default policy is "All Sales Final," which is ludicrous when endorsing products that have known (and now better known) fail rates.
  • It seems Aspire may have stepped in to help! Got an email moments ago from a rep, hopefully it plays out. :]
  • @Philip021 Perhaps you could let us know the outcome and who actually contacted you because it seems some of us are being totally ignored and others get a response?
  • @woodbar I sent a message through Aspire's site under "Contact Us" asking if there was anything that could be done to right the situation. I'll try and let you know what happens in the end.
  • @Philip021 Thanks - yes that's what I did as well - it seems they only answer certain ones then because there are many people on here, including myself, who have just been blanked!

    Keep us posted please and best of luck
  • @Tina Not sure who you intended that reply for - I am in the UK and buy my products direct from you in China as you know from my direct customer service requests?
  • @Tina Thank you, Tina, yes that is where the representative referred me to. Do you happen to know whom I should make the processing fee check out to?
  • @Philip021 you need send email to our after-sale service center in USA first:Service@uvaper.com
    or you can call them at:(253) 236-5251

© 2017 Powered by Aspire