Pegasus Temp Control burning coils

Since I've got my Pegasus I have not been able to get temp control to work properly. This is my first temp controlled mod and I'm not sure if I'm just doing something wrong or what.

I've put in the Aspire 1.5ohm nickel coils (using triton) and two times now it has burned out in a very short amount of time (once, the same day I bought it). Even when it is working, it tastes really harsh.
I've tried saturating the coils for 5-10mins before firing or running the auto detect thing that checks what coil you're using. I also talked to a guy at my vape shop who was telling me with temp control you have to lock in your resistance based on the room temperature or it won't regulate properly. He hadn't used a Pegasus yet but he said it should have a way to lock in the resistance. From the research I've done and all of Aspire's documentation I couldn't find any way to do that on the Pegasus. Is it just automatic with the Pegasus?

I really want to use temp control but I've had to stick with regulated for now (seems to work good with 0.3ohm coil and a set wattage). Is anyone else having this problem? Any solutions or things that I'm doing wrong?
DRDEEPGREEN
Comments
  • 12 Comments sorted by Votes Date Added
  • @Dawisch, temp control instructions are on the back bottom of the manual. I am using nickel also and have not burned any coils. However, I have noticed they do not last very long with the Pegasus using a Triton. My Atlantis V2 seems to work much better, keeps the flavor and does not burn at hot. :D
    Southy321
  • You should be able to regulate the resistance I would think.
  • @Joel360 I'd think so too, but it seems like the Pegasus is supposed to do that automatically or something 'cause I couldn't find anything about it in Aspire's documentation :-S
  • Maybe the Ti coils will last longer?
  • @Joel360 Maybe, but I haven't heard of people having trouble with the Ni coils in the Triton so I'm thinking it's something I'm doing wrong or a problem with my mod. A nickel coil shouldn't be burning out the same day I buy it. Somethings off there.
  • The resistance of your nickel coils will change as you vape them. That is actually how temperature control on nickel coils is accomplished. The microprocessor detects the resistance change as the coil heats up. Due to the smooth even plane of nickel's thermal conductive properties the microprocessor knows the temperature based upon the coil's current resistance. That said I am a little confused as to how you're burning out your coils. Could you give us more details please?

    Eric
  • @NoSmoking I have the odyssey kit setup. I put in an aspire 0.15ohm nickel coil, let it saturate for about 5 minutes, then hold down the fire until it switches to temp controlled mode. I'll put the wattage down to 1 watt before switching modes to make sure it doesn't miss-fire and burn my coil. After installing it and switching to temp mode I'll vape on it in the 400-520 degree range. It hits harsh on the throat even with a new coil. After prolonged use of a few hours I'll start to get burnt hits even with a full tank of juice. Eventually it gets so bad I have to switch out the coil again.

    I don't think it's the juice either because I've been using my Pegasus with regulated wattage for a few days and have had no problems.
  • I am having the same issue. I got the triton an was using it with a crappy eLeaf 50w, it worked alright but sometimes it would seem like the coil just went dry. I figured I should get some advice from someone that works at a vape shop. They suggested that using liquids that have too much PG (Might have that backwards, whichever is the thicker one) might be causing the coil to not soak up the juice quickly enough. So I tried a few different juices that where 70/30. Only one if these made a difference. Ecstatic juices.
    I figured that I should just get the Odyssey and start using the temperature control and that would solve the problem. The guys at Vape shop #1 said that should solve the problem and allow me to use any juice.
    However this is not the case. I got the Odyssey and the Ni coils. At first it worked really well, it was great when I had it maxed out to 600*
    But the next morning i go to hit it and it's like the coil has just dried up. It's just as bad as sticking in a coil with no juice and trying to take a rip off of that.
    So I turn it down to 350* to see if it's still burning, and it's not, and I am able to get it back up to 550(I'm sure I could have gone back to 600 if I wanted. But now it just periodically gives me dry hits. You would think that after letting it sit for a few hours the coil would be soaked and ready to go! Not the case. I often get a dri hit first, then turn down the temp to 400 and get a bit of a normal hit, from then on about 40% of the time I get normal good hits for hours at a time. The rest of the time it's an issue all day.
    I've never changed out the coil, it shouldn't be burned out, I haven't used it even 1/10th as much as I did a .3 coil.
    I am going to change out the coil now. Maybe this one is just shot from those dry hits. But after owning the Pegasus setup as a whole for 3 days I am not happy.
    If anyone has any ideas on what I should try please let me know. Feel free to shoot me a text (907) 351-5714 or e-mail me cog0289@gmail.com
    Any help would be appreciated.
  • edited September 2015 Vote Up0Vote Down
    while using the temperature control coil,when install a new coil,please let the tank stand up for 3-5 minutes to let the coil soak up enough e-juice,
    what's more,For the 0.15 Ni200 coil,the suggested temperature is 460 and 520,but we suggest that at beginning,please use it at a low temperature from 300℉,then add just the temperature a bit until getting the favorite flavor and vapor.high temperature will burn the cotton wick easily even with e-juice.
    If the cotton wick has burnt,even adjust the temperature to lower level,which will not solve the problem.only to change a new coil.
  • How do i go back from TC to normal watt mode? If i hold the fire button for four seconds if will turn back to normal watt mode BUT it burns out my coils. This has happened on more than one occasion. please help. thank you.
  • @mattheazn to be able to change back to wattage mode you need to remove the NI200 Coil. Replace it with a 0.4 (Black band) or the 1.8 ohm (Blue band) or which ever Kanthal coil you have, then press the fire botton for 3seconds then it will change back to wattage mode. Unless you fully understand Temp control mode, I strongly suggest stay clear from the Temp control coils. Otherwise you may harm your'e self and Aspire CAN NOT beheld liable for self inflected injuries
© 2017 Powered by Aspire