First Impression of the Pegasus

I'm going to keep this relatively brief as its late and I have a major problem with this device.

First impression - very, very good. It feels well made and great in the hand. I like the battery slot and the display.

I'm less impressed with the wattage adjust wheel - it serves a purpose, but has a tendency to decide to jump 10W at a time unexpectedly. I understand its supposed to go through the wattage faster - but I haven't got the "feel" of that function yet and I don't find it works well for me.

When the voltage is somewhere close to where it should be for the wattage (more on that next...) it can actually fire really nicely and give great vapour production, however....

Now - the MAJOR problem. When a tank is changed, the Pegasus correctly shows a new resistance but refuses to adjust the voltage regardless of what wattage has been set. For example - I like to fire one 0.5 ohm coil at 23 Watts. This coil is read by another mod at 0.46 ohm, the Pegasus reads it at 0.42 ohm. On the other mod I'd expect around it to fire at 3.25v based on a calculator - this mod reports that it fires at 3.25v. The Pegasus wont fire at anything like 23 Watts for at least 3 seconds - I have to actually fire it at 3.54v; this equates to around 30 Watts and you can feel (and hear!) the coil receiving too much power for those first few seconds before it ramps the power down and behaves properly.
I don't understand this at all - my other wattage adjustable mods adjust the voltage as appropriate and I get an appropriate level of power for the settings I've chosen.

I tried with two nautilus tanks both with 1.6 ohm coils (although they each read slight different on mods) - these fire at ridiculously high voltage compared to their rating. They start off at over 7v - that's 30 watts being pushed through a coil that reads 1.69 ohms. How can this possibly be acceptable?

Now to make this even worse - I tried this on a low end dripper. Fortunately this didn't cost me anything - but that was reading at about 2.01 ohms. Note the past tense - was. In less than the three seconds it took for the Pegasus to adjust to a sensible voltage it popped the coil and that dripper is now dead.

Note - during that first press and hold period, your selected wattage is not applied and far too much power is pushed through your coil.

@NoSmoking please could you get in touch with me to talk this through? I don't want to say more here before discussing this with someone from Aspire - however the Pegasus pushing significantly greater voltage through a coil than it was designed to take is a massive problem that other users should be warned about.

Now - if I'm missing something obvious here then I'll publicly state it was my mistake - however, this is a regulated box mod - this massive amount of power should not be pushed through the coils in this way, in my opinion.

I've ended up elaborating more than I first planned to - but I think there is a possible safety issue here that other people need to be aware of.
I hope everyone who has their temp control Pegasus has had a better start with it than I have - but please take the feedback from my problems and be safe.
charlzrocks
«134
Comments
  • 105 Comments sorted by Votes Date Added
  • I should add here that I do appreciate the opportunity of trying out the Pegasus very early in its release cycle. I have placed my feedback here not to attack Aspire in any way - but to provide feedback which can hopefully improve a product that has so much potential.

    This is also to provide other users with the benefit of my bad experience in the interest of preventing them having a similar (or worse) experience.
    charlzrocks
  • @viruk My Pegasus is pre-TC and with a .5 0hm (reads at .46 Ohm) Atlantis coil at 25 watts it fires at between 3.39 to 3.42 volts. I do not know if this is unusual as it is my very first box mod. However, my hits do not last longer than 3-4 seconds so I do not think that it is overpowering the coil (at least at this point, 2nd day on the .5 ohm coil) At 30 watts the voltage is 3.71 to 3.75 volts. I prefer 23 to 25 watts for the sweet spot on my juice. I am pretty sure that this is fine....but again I am not as well versed in the electricity as some of the other forum members. They might be able to give you the information that you are looking for! :-B :-??
    Viruk
  • @Viruk, I am currently on 30w, showing .39 on an Aspire .40 coil and when I fire it shows 3.33 to 3.37V. I seem to be vaping fine. I am not well versed in electricity either so I would like to know some parameters to look for also. Also I would like to know which battery did you recieve: the 1800mAh or the 2500mAh?
  • Viruk said:

    this equates to around 30 Watts and you can feel (and hear!) the coil receiving too much power for those first few seconds before it ramps the power down and behaves properly.
    I don't understand this at all - my other wattage adjustable mods adjust the voltage as appropriate and I get an appropriate level of power for the settings I've chosen. .

    Hi Viruk, i raised this issue in the "Pegasus TC wings" thread.

    The Pegasus first delivers 30 watts (to test if a TC coil is in) whatever power you have set. Which is much more power than a little 1.8+ occ coil can survive.
    The problem is the same when you want to switch from TC to normal "wattage" : you're obliged to make fire for 4 seconds with the new tank attached to the Pegasus, and the coil first take 30 Watts.

    The few reviewers here seem to only use the TC feature or sub-ohm near-0.5 coils in wattage function, so they will not notice this overpowering, or it won't be an issue.
    Guys try with a RBA (0.2 or 0.3 kanthal @ 1.8ohm with organic cotton) or an old little tank (i.e. protank2 with vocc coil), your coil will just burn, taking the "test" 30W.
    The power will adjust to your settings after but it's too late : once your cotton is burnt, it's burnt and the taste is awful.

    About the TC feature : it's more a limiting system than a regulation system : you can hear the Pegasus heat/stop/heat/stop/heat/stop to prevent the coil heating too much. Temperature control devices will adjust the power gradually to keep the temperature and show the joules/watts decrease and stabilize.

    IMHO all in this device is great except the TC "30 W test" / 4 seconds fire : users should have the choice to switch between TC<->normal whenever they want with 3 or 4 clicks, and the "30W test" should be removed or active only when TC mode is first set. Otherwise the Pegasus is just unusable with certain devices / RBA sets.
    Viruk
  • Part 3

    I have just noticed that the top chrome panel is already starting to scratch where the edge of the Triton contacts it. In view of the fact that these two devices are sold as a package and I am always very careful to only gently "snug" fit my devices to the mod ( to prove it I have two regularly and much used iStick 20w devices, with the soft brass threading and they are still pristine) then that has not been well designed at all. As another example I can screw the Triton or Nautilus onto the Cool Fire IV all the way tight down and it does not contact the top plate - it looks as though it does but if you hold it up to the light you can see there is a microscopic gap.

    Bottom line - so far I am extremely disappointed - why?

    Wonky display, sharp corners, a bit too heavy, scratched top plate, cotton burning set up procedure EVERY TIME YOU CHANGE THE TOPPER!

    I actually ordered a non TC Odyssey kit as was originally listed on the website. After some delay I was sent the new "upgraded" version and although the delivery process was exemplary, the actual device is NOT what I ordered and appears to burn the cotton in your coils if you remove the device and refit them or change devices.

    I understand that if I had ordered this to use for TC (I did not as it was not listed at the time) or for sub-ohm use (also not a requirement for me) then I may have been more impressed BUT as it stands at the moment, IF YOU WANT TO USE THIS FOR NORMAL WATTAGE VAPING WITH 1.6 - 1.8 OHM COILS THEN I SUGGEST YOU LOOK ELSEWHERE!

    Don't get me wrong, I generally think Aspire products are excellent and well made and I currently only use Aspire atomizers, Nautilus, Nautilus Mini, Triton, K1 and ET-S etc. - but they have dropped the ball on this one.

    Sorry, it is not as described when I ordered it or fit for purpose and is unusable for me. Unless there is going to be an update in the form of firmware or replacement then this is going back in the box and heading back towards China.
    charlzrocks
  • edited August 2015 Vote Up1Vote Down
    @pia I have not done as much testing yet as yourself but I agree with everything you said.

    The problem is that it would appear to be the case that if you want to use the Pegasus with coils over about , say, 1.0 ohm the only option is to use the Triton with a 1.8 Triton coil AND then make sure you only ever let it do its set-up burn-in routine once on that coil!

    You could take it off to clean or fill IF you remember to LOCK the device first but, in effect, it means once you start using it on the Pegasus you have to CONTINUE to do so until you decide the coil is toast, otherwise you risk damaging the coil prematurely if it has to suffer repeated burn-ins. If you change to another device then later refit your Triton it will do its set-up burn-in again and it would seem, depending on the PG content of your juice, that you might get away with this twice - any more and you start to get the scorch taste creeping in.

    Not an ideal situation is it and I don't recall Aspire stating that you could ONLY use it with Triton coils IF you wanted a 1.8 ohm setup?

    It is a great pity as I have just "tricked" it into accepting a new 1.8 ohm Kanthal in my Triton, by locking it before the change, and the result is a superb vape at 14 watts - I might just be having a good flavour day - but the Triton has always tasted a bit "sweet" up to now but on the Pegasus it is giving me great flavour, vapour and the sweetness has all but gone. (Yes it is my normal mix and it IS NOT a sweet flavour at all). I know that sounds implausible but that's the impression I am getting today - could just be because there's not an "R" in the month!
    Sherryremy
  • @Viruk I am skipping the nickel altogether and holding out for Titanium wire to try some wraps. I think a couple more days before I get the wire. I will definitely post my findings here. Sounds like I might want to start with a double coil on an old RDA to get resistance, and work down to trying out my subtank and possibly the Triton RTA.

    @woodbar I think it's funny you mention the sweet taste in the Triton. I generally vape a tobacco flavor in that tank, partly because it is difficult to change flavors, and have noticed it does taste sweeter than my Nautilus tanks. I figured it was just the sweet taste in the juice coming out better in this tank...
    Sherryremy
  • edited August 2015 Vote Up1Vote Down
    @woodbar I'm guessing that when it comes to the Nautilus Tank that you like to use (this will only work with Nautilus 1.8Ω Coils) and the Triton Tank with the 1.8Ω Kanthal Coil. A work around, so you don't have to do the Pulse, when you want to switch between a Triton with 1.8Ω Kanthal Coil and the Nautilus Tank (would have to use 1.8Ω BVC but couldn't use the 1.6Ω Nautilus BVC's). Is before you remove the Triton Tank "Lock the Pegasus Mode" and switch to your Nautilus Tank. So in theory you would only have to do the "Pulse" the first time you connect your Triton Tank with 1.8Ω Coil & never again as long as you stay with 1.8Ω Coils. As long as you "LOCK" the device that is. Otherwise, I would recommend breaking-in a new 1.8Ω Triton Kanthal Coil on a different Mod before putting it on the Pegasus when it's brand new (put a tank of E-Liquid through it on a different Mod and then switch it to the Pegasus). I'm hoping to test this theory in my review, but I donated all my Nautilus Tanks & my Mini to my family and friends when I upgraded to the Atlantis Series Tanks, when I started sub ohm vaping. I'm hoping to get my hands on one of my Nautilus Tanks by this weekend from a family member (I didn't want to ask my friend to borrow the tank I gave him b/c it's his only good tank and don't want him to have to use his gas station special for a week while I test this theory.. lol that would just be wrong and I don't want him to go back to cigs).

    I finally got my USPS order with all different Ohm Resistance on Kanthal Coils and also Temperature Control Coils both Ni200 & Titanium. Then my Kanthal A1, Nichrome (Ni-Cr), Ni200, Titanium, & Ti-Cr wire order will be here on Friday (from 22Gauge thru 32Gauge). It will be like Christmas for coil building. hehe I got a Triton 1.8Ω Coil from my uncle and have one laying around that I took two hits off of, and sat it aside a couple of weeks ago because the draw was to closed for my style of vaping but I'm going to put it in my tank tomorrow and give it a full day (see if I get the scorching or burning taste people have been talking about)..

    Will be posting my full review on the Pegasus this weekend once I had time to go through all the coils I've received and a couple of builds to test). More to come & best of luck for now.. B-)
    charlzrocks
  • I think the majority of people here are experiencing some issues with the mode switch and the 30w pulse - but there are still some really nice aspects of this mod.

    A friend came over last night and we decided to try some Kanthal builds. I haven't gone back to the NI200 for a third attempt at TC yet but hopefully will try that again soon...

    Back to last night's experimentation - we built one single and one dual coil set up at 1.08 and 0.49 ohms respectively and they both vaped fantastic on the Pegasus. The bonus with an RDA is that the initial firing to eliminate hotspots (without wick or juice to burn) can be used to get to the wattage actually required for firing, but this isn't really a problem with the 0.49 ohm build as its good to fire at over 30w.

    I do still like the look and feel of these mods and I think they look great with the appropriately coloured Mutation RDAs :)
    This is the Chrome Pegasus with the stainless RDA and the slate Pegasus with the black RDA - we were certainly chucking some clouds with these last night!

    I'm still waiting to talk to Aspire (I did get an email saying "no smoke" was going to contact me? maybe @NoSmoking ?) - but I'm finding ways to enjoy the Pegasus in the meantime :D
    Southy321
    double dripper.PNG
    518 x 672 - 576K
  • I just thought I'd post a little update, moving on from my earlier post about having no issues with Aspire made Nauty coils and the Pegasus.

    Whilst always taking heed of Aspire advice on time to leave new coils to saturate, I have now had two burnt coils. One was very old and on its way out anyway but the other was a brand new one, fresh out of the blister pack. It was left for over 30 minutes in a full tank, first fire of the new 1.6ohm coil and the detect phase burnt the wick.

    I agree with the OP that this isn't a completely flawed device. If you're using something like a Triton or Atlantis, I imagine you'll be quite impressed with it, but it's not without issue IMO and despite the testing Aspire have seen no issues with, in the wider user testing arena, it seems that the 30W test fire can cause issues unfortunately.
    Viruk
  • @Viruk Yes, all very strange. It may just be you got a duff one then, but hopefully you will find out for sure when your prize arrives.

    Unfortunately I did not get mine via the offer - not even sure how much that was in GBP - but I think you got the dock and a battery thrown in?

    I went for the Odyssey kit as it was a bit of a saving over the individual items and I wanted a second Triton so it seemed like the way to go.

    I have got one Ni200 coil that came in the kit but I have not had the inclination or nerve to try it yet and I am still waiting for a response to my query with CS - so I have only actually tried the Pegasus part of the kit in case it all needs to go back.

    It's a shame as I have liked and recommended Aspire kit for some time but I was not that impressed with the ESP30 (allright but very basic and a poor display) and as you say the Pegaxus has a lot going for it (display, build quality and finish etc.) but this auto-mode thing and 30 watt test fire is a complete let down and unfortunately it is putting people off buying it. I have even seen comments on FT about the problems (but I think you know that?)
    Viruk
  • edited September 2015 Vote Up1Vote Down
    @Viruk .... I have a fix.... maybe its already posted, but I hate reading tons of posts. mine does the exact same thing...

    here is the fix...

    remove battery
    install tank
    reinstall battery, quickly shut battery door and quickly press the fire button and hold it while its still reads "Aspire" on the screen. soon as the word "Aspire" goes away, it will work like normal again.
    this was very embarrassing for me. I was at work, bragging on this mod. I took my tank off and let another person use it. it burnt their coil, then I put mine back on and it burnt mine. it's like it was stuck on 70 watts, but only said 12 watts on my screen..
    hope this helps you and others.... and I hope ASPIRE addresses this!
    Viruk
  • @Big AL OK, thanks for that - another "trick" routine for the Pegasus, I will try that later.

    Could you clarify what mode you were in, TC or Watts, before and after the method you describe?

    Obviously I think what everyone would like to find is a trick to get it to switch modes?
    Viruk
  • @bigal Also, if you scroll up through this page you will find my earlier post describing 2 other methods for stopping the burn-up routine!

    I must say these were not discovered by me but I thought it was a good idea to put them all in one place so I may do another post later with all 3 o ce I have had a chance to verify.
    Viruk
  • This is very worrying.

    My intentions for the Odyssey kit I have ordered were to use Kanthal coils in Nautilus and Tritons ranging from 1.0 to 1.8 ohms (premade or RTA).

    If I have to blast the coil with 30 watts of power for 4 seconds everytime I change resistance then obviously it will not be fit for purpose?

    Strangely enough I mentioned my concerns on another thread last night stating that I might cancel the order - having read the op above this morning decided I would - before I could got an email saying my Odyssey kit + coils had been dispatched!

    Odd thing - I got free carriage due to my invoice amount but they have sent via DHL - which has never happened before?
  • @charlzrocks thank you very much for taking the time to respond - I know currently its a small pool of people who will have experience of this mod

    @milmil0428 the 2500mAh battery was in the mod. I ordered an additional battery which was still the original 1800mAh thinking I'd have a pair - now I have one which doesn't do high discharge so well.

    @pia this is exactly the problem - delivering 30 watts to a device (when the correct resistance is even displayed on the mod) is absolutely ridiculous. I bought an RDA and some nickel coil yesterday but I'm really unsure of the quality of this mod and whether I should risk this thing over heating nickel as there are potential health risks involved with that.

    I also agree that this device has a lot to offer - but the idea of firing for 30w for (up to?) 3 or 4 seconds had got to be the most ridiculous design decision I've heard in a long time.

    @Tina @Nosmoking or anyone else from Aspire in general - I'm really disappointed to have not heard anything official from Aspire on this thread. I'm eager to discuss this with you
  • @woodbar I also asked about the firing for several seconds to change modes before any of these were shipped and no answer was given.

    I completely agree with your comment about it being fit for purpose.

    Mods have all moved towards being regulated and safer devices - then this one comes along and expects us to put 30W through a device before the real wattage we set is actually fed to the coil.

    Free carriage over a certain value will now be via DHL - there was an announcement about that somewhere
  • @Viruk Well DHL now advise I will receive it by close of Monday 24th - which I must say is brilliant service, tempered by the long wait since ordering of course.

    I am hoping that there is a "trick" fix to this problem that you and others (and me no doubt, very soon) are experiencing. I have noted that several posters have mentioned the possibility of a firmware update via USB port but I do not believe there has been any official response from Aspire?

    IF they have updated the devices from the original design to TC just by firmware via the USB then we may be in with a chance - BUT, even if it does have data signals available on the port, IF that is a non standard interface, for example requiring a particular voltage on a specific pin to enter upload mode, then no way!

    I do hope this just turns out to be a slight "snag" else I can see a lot of Pegasus mods heading back to China!
  • When the device is settled after a coil change it seems to be ok, and this is not so much of an issue with sub ohm setups that are fine with 30W being cranked through them for a couple of seconds. But - this is a major problem for anyone wanting to use this mod with higher resistance coil/tank setups.

    @woodbar I don't think the change to TC is only firmware - I don't know for sure, but I'd be very surprised if there wasn't a more fundamental change than just firmware. I'd guess a different chip would be required - but I'm hoping there is EPROM or similar on that chip that could allow us to update in some way.

    There is a lot to love about the Pegasus - but I'm finding this current problem a major obstacle at present.

    I've raised a support ticket with service@aspire.com and I'm hoping I can speak to someone from Aspire about this. I just want to be able to feedback to Aspire about my experience, maybe get some more advice, work out whether my issue is the exception or the norm and possibly provide information that Aspire can use to make further improvements.
  • I've had mine for a full day now and here is what I have noticed:

    Right out of the box I popped a Nautilus mini with a 1.8ohm coil on it. Sure enough it showed at 30 watts and burnt that coil to a crisp. I cleaned the tank and put in a new 1.8ohm coil. I changed the wattage to 12 and fired and all was good. No spike, no forced 30 watt check. I changed the tank out for my regular Nautilus first with a 1.6ohm coil then a 1.8ohm coil. Both times, having fully removed the tank from the mod to change coils, I dialed in my preferred wattage and everything worked fine again.

    I feel that if I had paid attention when I first unpacked it and had changed the wattage I would have had no problems from the start, but I'll never know. I am absolutely positive that my mod has not fired at 30 watts (or any wattage higher than what I have selected) since that initial time.

    I just popped my Kanger sub plus with a .5ohm coil on and watched the screen. I dialed in 18 watts and the display did not change from that. I would have assumed if the mod required a 3 sec push @ 30 watts to verify your coil then it would have displayed 30 watts. Second fire I vaped and it tasted just fine.

    This is more anecdotal that helpful as I can't really address the problems you are having, and that I got 2 emails from Aspire outlining as a warning, but this is what I have observed.

    My biggest problem is trying to watch the ohms and volts jump around as I vape. Not possible to see the screen but I want to! And the other problem being it doesn't appear as if there will be nickel or titanium coils coming out for the Nautilus or Atlantis tanks, which sucks. I keep reading the Triton leaking posts and am cautious to buy one, but it looks like the only problem tanks are the ones that came with the tiny, ill-fitted clear o-rings early on. I'll do some more reading on that or worst case I'll have to go with a non Aspire tank to TC :(

    Peace & Happiness
  • @Viruk I think you could be right about more than firmware, possibly a chip change or whatever - if they had to do that it will have been expensive in time and resources!

    I look forward to hearing about the response to your support ticket.

    @Munroebagger Thank you for sharing your experience so far. It is strange that your results (after the initial burn up) seem at odds with at least two other users and somewhat more encouraging?

    I am not, for one instant, suggesting that anyone has got it wrong - except, just maybe, the programmers @ Aspire of course?

    Could it be there is, as yet, an undocumented procedure to get the mod to change coil resistances or modes WITHOUT shoving excess wattage through any unsuitable coils? I am thinking along the lines of lock the device, or remove the battery, or press and hold the fire button, or standing on one leg with one arm behind your back........ before screwing a new atty on the device?

    Peace and Happiness - well that is a lovely thought and I agree with you - trouble is there are a lot that don't understand the concept!
  • @Munroebagger Aspire are releasing temp control coils - they just weren't available (yet) last time I checked, but they are coming and will be 0.15 ohm coils with a red ring

    Also, I'm not sure what it is that causes the recalibration to occur. It doesn't seem to necessarily do it if I change from a 0.4 to a 0.5 ohm coil, but its inconsistent. Sometimes it will, sometimes it won't. It almost certainly does cause this 3-4 seconds @ 30w if changing from a sub ohm coil to say a nautilus at 1.6 ohm.

    I haven't tried TC yet - despite buying an RDA and some ni200 wire. I want to see some more experiences from other people before I take that risk. The last thing I want is trouble with the mode with a coil that could be around 0.1 ohm.

    No response from support yet - but it would have been late afternoon early evening for China by the time I emailed them - so I may not get a response until Monday. That's not so bad, but I know that someone from Aspire was on the forum at the time I posted this thread (although that was after 2am my time), I kind of hoped someone may have been able to answer before I got up and checked this morning.

    @woodbar I certainly hope there is a way. The documentation discusses this holding the fire button for three seconds as the way to swap in to TC mode - but I haven't even used TC yet. I've got used to swapping tanks around quite a lot - especially if I'm sat at home or trying juices with friends. Having to go through 3 (or more) seconds of firing at 30w every time I change a tank is no good at all.
    A much better approach would be to swap between temp control and wattage mode by holding the fire button while the device is locked!
    The idea of forcing any current through a coil when you know that the wattage is wrong is just completely flawed in my opinion.
  • Update at the close of the weekend.

    I have avoided using any coils of higher than 1ohm resistance to avoid popping another one. When sticking to coils around 0.5 ohms, allowing it to calibrate doesn't force too much voltage through the coil. Then once its settled and actually adjusts the voltage to give you the wattage set it works quite nicely.
    I've been enjoying it with my Tritons and an iSub G tank and I am actually quite pleased with it for that use.

    This evening I decided to try a nickel coil build for an RDA to try out temp mode. I couldn't get any NI200 coils so I bought an RDA and some NI200 wire. I had a couple of attempts at a single coil build as the resistance was going to be too low on dual coil.
    I had resistances displayed of between 0.07 and 0.12 ohms along with a couple of "low resistance" messages.

    The Pegasus did fire - but only in wattage mode, it wouldn't switch to temp control mode even when fired for almost 10 seconds. The coil was heating up and no other message was displayed but I just couldn't get anything regarding temp control going.
    I ended up abandoning the attempt as its getting late, sticking the RDA through the ultrasonic cleaner and I'm wondering what I can do differently...

    I maintain that there is a lot to like about the Pegasus and charging dock, but I feel there must be a better way to switch modes.
  • @Viruk This is getting even more odd then?

    Have not had a chance to check but I seem to remember that the build should be less than 0.1 ohm for TC? Or did I imagine that. If so that could be why your 0.12 stayed in wattage mode?

    Have you actually tried all the different button combinations - such as holding fire and turning the adjuster while locked etc.?

    I still think (hope) we have not been given the whole operating procedure yet for these devices - OR the logic developers had a bad day - "IF we can't get it right THEN release it anyway ELSE we'll be in deep s**t"!
  • edited August 2015 Vote Up0Vote Down
    Dear friend,
    thank you very much for enjoying our product and sharing your experience with us, after confirming with our engineer team about this problem you mentioned, here are our suggestions as below:

    1. When installing a new coil , please let the tank stand for 3-5 minutes, so the cotton can be saturated with e-juice before firing to avoid dry burning.

    2. When attaching a new atomizer please be sure to press the fire button for at least four seconds to let the Pegasus check whether or not the new atomizer is a temperature control coil or otherwise, then it will change to the corresponding mode according to the coil material. At this time, the battery wattage will reach to 30 W only in about 1 second, when user uses a high resistance coil, there will not be any damage to coil in this 1 second. Besides, we have finished thousands of tests when designing the product, the test results shows that the coil will not be damaged in the recognition time.

    3. If the user used a Sub ohm coil (such as 0.3/0.4/0.5ohm) in previous Wattage mode and set a high wattage (30W-70W), when changing to Wattage mode again from Temperature mode, the battery will remember the previous wattage data and then output with this wattage. So, when user changes a high resistance coil and turns to Wattage mode again, please mind the screen display, once successfully changing to Wattage mode, please immediately loosen the button and decrease the wattage to the required wattage of coil before use, this will avoid burning the coil due to inappropriate wattage.
  • edited August 2015 Vote Up0Vote Down
    @woodbar To enter TC Mode the resistance of the coil should range between 0.1Ω to 0.15Ω.

    It says that if a Ni200 or Titanium Coil/Wire is above 0.15Ω that you can use TC Mode but it will not display the Ohm Resistance on the Pegasus Screen higher than 0.15Ω. But t o my surprise I'm using a Ni200 build at 0.17Ω & another at 0.28Ω in TC Mode and the Pegasus reflects the correct Ohm Resistance on the screen as I was getting on my multimeter. But it was recommended to use TC Mode with a coil resistance between 0.1Ω to 0.15Ω for Ni200 Coils/Wire Builds. I'm loving the Pegasus in Temperature Control Mode over my IPV3-LI at the moment. I'm going to use the Pegasus for a week before I do my full review, since I have some more Ni200 Coils, Titanium & Ni200 Wire, and some new Triton coils with 3 different Ohm resistance being delivered tomorrow. I want to review all aspects of the Pegasus before I post my reviews. But thus far it's amazing and loving TC Mode since Friday. Vape On and thanks for the amazing opportunity Aspire!! :D :-bd
  • Kiki Chan said:

    At this time, the battery wattage will reach to 30 W only in about 1 second, when user uses a high resistance coil, there will not be any damage to coil in this 1 second. Besides, we have finished thousands of tests when designing the product, the test results shows that the coil will not be damaged in the recognition time.

    Hello Kiki chan and thanks for your answer,
    the first 30W for 1 second will not damage the coil itself, but rather burn the cotton whick (burnt 2 vocc in a protank2 here). Once it's burnt, the burnt taste remains
  • piapia
    edited August 2015 Vote Up0Vote Down
    I just made the test once again, and burnt a third coil. Video attached. All here can do this test.

    - Pegasus in VW mode at lowest value (1W)
    - Attach a protank2 with 1.8VOCC coil (or on a RBA/RDA make your own coil with 0.2 wire and organic cotton)
    - First and for a (long) second the coil takes more than 7 volts and after your setting (1W) is applied
    - As a result the cotton tastes burnt and will keep that taste (the tank sit all night to be sure it whicked very well)

    http://sendvid.com/gdhlg9k1



    The Pegasus is a good device but i am so disappointed i can't use it with my usual setup : i have a Trition tank with RBA for sub-ohm high-VG vaping (no problem), and my second daily setup is this protank 2 with vocc coils for fruity high-PG juices...unusable with the Pegasus

  • @Southy321 OK, my mistake on the coil values - very glad the Pegasus is working out for you.

    @pia Yes I agree with you I would not want to shove 30 watts through even a 1.8 coil unless it was totally flooded with a very thin juice - and even then it would be risky. They say it will handle coils up to 5 ohms as well - I think this might be called a "portable hand warmer" when it checks coil resistances nearing that value! Luckily I think coils higher than 1.8 ohm are pretty much extinct these days.

    I think there should be a positive, user selection, to enable either TC or wattage mode and, like my iStick 40w TC, IF you select the wrong mode, say TC for a 1.6 ohm coil, it just jumps back to wattage (@your last setting) automatically.

    DHL courier just arrived at my door so I will be able to make further comments, later, from first hand experience. I am impressed with the delivery - left China on Saturday and arrived with me in the UK on Monday morning - I just hope the device is just as impressive - watch this space.
  • edited August 2015 Vote Up0Vote Down
    @Kiki%20Chan while I appreciate the time taken to reply, I have the following responses to your suggestions:
    1. This has nothing to do with my reported problem
    2. this is exactly the point that my query relates to - this is not performing as expected especially with regard to temperature control, however this process has run my nautilus tanks at too high a wattage and blown the coil on a cheap dripper.. So regardless of your testing - I'm telling you that I have experienced this "in the field" and I am looking for support to resolve the problem - I am eager to discuss this with someone.
    3. fair point about setting the wattage - and definitely something to watch out for; however the whole point of my query is that the wattage set is not respected during this calibration phase, and this is long enough to cause problems/damage to some coils

    @Southy321 It's reassuring for me to see you've managed to get in to temp control mode, however I was unable to do this even when my NI200 coil was reading 0.11 ohms. I had set the wattage very low when I tested this so was only firing a very low voltage through the nickel coil - however all of the reading I've done about Nickel coils tells me that firing a Nickel coil in wattage mode is a very bad thing to do - hence my concern.

    @pia thanks for posting a video - its reassuring to know that I'm not the only one to experience some problem here; but your video does show that the Pegasus successfully dropped the voltage from 7.6V down to 1.38V - the very non-scientific method of counting makes me estimate this to be after about 2 seconds.

    @woodbar good luck with your testing, please let us know your results :)

    I repeat - when used in certain conditions I'm really happy with the Pegasus.
    However I couldn't get it to change to temperature control mode at all, my experience with my nautilus tanks is very similar to @pia 's experience shown above - so I don't even try with those now and I have an ongoing concern about pushing power through a Nickel coil before its swapped in to temperature control mode. Raising the temperature changes the resistance and I've seen that the initial read of a Nickel coil on a DNA 40 needs to be done while the coil is cold - I'd like to discuss this last point in particular with someone from Aspire.

© 2017 Powered by Aspire