Triton and CF VV+ problems

I am using an aspire CF VV+ battery with the Triton and a 0.4 ohm atomizer. When ever i press the fire button it flashes 3 times and indicates a short. I tried 5 other brand new 0.4 ohm coils and they did not work either. 2 of the coils i tried dry firing without any juice. I also tried the Triton on another battery and it still indicated a short. Why would this happen?
Comments
  • 1 Comment sorted by Votes Date Added
  • edited August 2015 Vote Up0Vote Down
    @skull905 I am sorry that our CF vv+ battery is not compatible with our Triton tank.
    For the output wattage is not enough to fire the tank.our CF vv+ is voltage adjustable battery,in order to get good vapor and flavor,it is better to use 1.6-1.8 ohm coils.
    So when you attach the triton tank to the battery,it flashes 3 times and stop output to protect the battery and the tank.

    You can try the triton tank on our new Pegasus TC mod.
    What's more,we make Ni200 0.15 ohm temperature control coil for the Triton coils,it can also works for our Atlantis 2 and Mega.
© 2017 Powered by Aspire