Warm prompt for Aspire Pegasus Temperature Contol

Dear Friends,
Do you get your aspire Pegasus mod with TC?
Before using,Please take a little time to read this Warm prompt,which will help you enjoy the TC function of your aspire Pegasus .

1280 x 650 - 475K
0821.jpg 475.2K
  • 8 Comments sorted by Votes Date Added
  • Hmmm, I stuck a 1.8 Ohm coil in my Triton and didn't have any issues on the Pegasus. I wasn't even thinking about the TC mode at the time. I am waiting on some Ti wire so I can give the TC a real shot and will post my review. So far it seems like a really nice mod. Definitely a lot more than is needed for the 1.8 Ohm coil... LOL
  • @woodbar So I removed the battery for a few seconds and put it back in and it immediately went into TC mode (it was in TC mode before removing the battery), but now it does look like it's properly switching between TC and wattage modes if I hold the button for 4 seconds. So far it looks like it's working normally. I had actually tried pulling the battery out previously but I guess I didn't remove it for long enough.

    If I have one piece of feedback for Aspire on this, I'd say that making it swap modes by holding the button for 4 seconds was a really bad idea because normal usage leads to accidental swaps between modes. It would have been a much smarter choice to do it based on doing 3 or 4 clicks or maybe another sequence the user is unlikely to do on accident like holding the fire button and turning the wheel at the same time.
  • Thanks for the info Tina. ;)
  • @Tina have you considered what happens to coils of higher resistance when 30w are pushed through them?

    The sub ohm Triton coils can handle this, but the nautilus coils can't and I've had a cheap dripper pop on me because of this.

    Please see:
  • So I've run into a problem with this feature. Everything was working fine for a while since I was using the wattage mode and I really liked it. Somehow it switched into TC mode on me (I suspect maybe I took a really long pull off of it). It sort of worked in TC mode, I like to run it on the cooler side so I dialed it down to 200 and it seemed to work OK like that for a while. Then it stopped firing. I push the button, and it displays 200, but nothing happens. If I detach the atomized and re-attach it, it will start working again for a while but eventually it will stop firing again. I tried to switch it from TC mode back to wattage mode since that seemed to work, but nothing I tried seemed to be able to switch it back. Holding it for 3 seconds, or 4 seconds did nothing, I even tried holding it longer and did it all the way to the point the 12 second cutoff kicked in. I eventually did get it to switch back to wattage mode but only by swapping the atomizer out for a kangar one I had lying around. It worked fine for a while in wattage mode, but now its swapped back into TC mode on me, and once again its stopped firing. Is my unit defective or something?
  • @orclev Obviously it should not be arbitrarily switching between the two modes when using the same coil - it should only ever select TC mode when you actually have a TC capable coil in the tank. What coil are you actually using?

    Could I suggest you remove the battery for a few seconds then put it back in and see if it makes any difference? This has cured a similar problem where the Pegasus refused to auto-switch into TC mode so it might be worth a try.

    I assume your coil is screwed down reasonably tight and the 510 connection is clean?
  • @orclev OK, I am glad you are sorted - it is amazing how many times the old cliche of taking out the battery or turn it off at the wall actually works!

    You have come to the same conclusion regarding switching modes as many, many other people have!
© 2017 Powered by Aspire