Triton RBA Question

Hello! My first time purchasing an aspire product was the Triton. I ordered the rba section and it arrived today. after inserting the stock coil and wicking, I noticed that the bottom set screw was not making contact with the lower wire lead. i tried to tighten it a bit more and the screw broke. i got it out, and tried another screw, but that too would not make contact and the wire just floated in there. any thoughts on how i might fix this issue? Sorry if this isnt the correct place to post, but i dont use forums very often. thanks for any help!
Comments
  • 17 Comments sorted by Votes Date Added
  • MY Personal Opinion, Observation here: Every time I watch someone doing a build, either on video or actually watching someone, I cringe when ever they go WRENCHING down on contact screws. Why? They over tighten them!

    Every screw, nut, bolt has a specified torque rating, defined by the material it's made of, and the thread specifications. Generally speaking, the smaller the thread the less torque it can handle.

    So, yes. The set screws in the Triton RTA can break, strip, as you found if you over tighten them. You only need enough torque to keep the coil leads in place. There is enough contact area for the leads on the opposite side of the set screw to allow the current flow through nicely.

    And yes, I understand on a RDA head, that people want a strong connection so they can readjust the coil when it's connected (to make it parallel, or fix what ever alignment issues they have).

    And I've always said "You know with a little pre-planning and maybe taking an extra moment to pre-bend your leads, you won't have to do all the heavy twisting of the coil to get it lined up, and not worry about striping your hold down screws.", but no one listens to me. They just say "It's easier this way!!" as I watch them strip the threads on the screws or bend or break a post and start cussing that they bought a piece of junk.

    BUT, that's just my personal observation.
    Old_SaltSouthy321Viruk
  • Do you mean the connection at the base hardware of the tank or the screw used to secure the lead of your diy coil on the bottom of the RTA?"
    charlzrocks
  • WASTE OF 10 TO 15 DOLLARS SMH
    charlzrocks
  • my issue with the RTA system is the fact that it will not hold any kanthal at all. Have even tried 24g the screws dont go in the hole enough to catch the kanthal. Has made this thing totally worthless to me :( I never got to putting the bottom on due to the top part not holding the coil in.
  • I've already broken the two screwheads that fastens the coil itself inside the head. I've got two in spare which came with the kit, but I've never experienced such low quality screws included in an RBA-head. Even knock-offs of tanks and drippers perform better! I've been building my own coils for about two years, so I consider myself experienced.
    I don't thighten the screws particularly hard, not more than needed for keeping the coil in place.

    Is this a common and/or known problem? How do you address this?
    The screws are so small and specialized that I don't think this is something kept in stock in my hardware store either. And I don't plan on buying a new RBA-head every other week just to get new screws...
  • Other than the usual coil forming tools, I recommend a miniature jewelry pliers set. Make sure you include flush cut pliers. The right tools make a difficult job easy.

    Do not bend to break excess wire off of your coil when it's in your rebuildable. You can strain the posts, or expand the wire so it's not easily removable.

    Snug is good; tight costs money for repair or replacement! In my business, I charge $10 for an extraction, $15 for extraction with a helicoil insertion PER HOLE. No guarantees, you pay for my time and effort.

    It's cheaper to buy a new RDA than the tools to extract a broken miniature set screw such as those found in an RBA, RDA, or the Triton's RTA. It costs over $50 USD for the set.
  • I also have the same problem the set/grub screw that holds the wire at the bottom (positive) won't grip onto 24 gauge wire.Having looked at it , the set screw only goes about half way in .
    Kinda makes having bought the RTA pretty useless.
  • I'm guessing from lack of response from aspire "staff" this is just a quality control issue and it's being ignored ?
  • I love the design and function of my Triton tank, but the RBA is a piece of shit.

    It is way more complicated than it should be.

    Compare the Triton RBA to the Kanger sub tank mini RBA or the Smok TFV4 RBA.

    You will see what I mean.
  • @JSHoward11@gmail.com we understand your frustration...however, please refrain from using profanity on the Aspire forum. There are better ways of communicating displeasure with a product. Thank You.
  • I have no problems using 24 gauge wire got it to .4ohms maybe user error.
  • I just have to mention that I tried my first twisted 24 g vertical coil in the RTA, and it is awesome! Came out to .50 Ohms, and I used 5 wraps on a 3.0 mm tool. It hits nice in a wide range of Wattages, depending on the temp of vape you like. I am still doing mostly mouth-to-lung, but tried a couple straight lung hits for kicks, and it is pretty sweet. Next I will have to try twisted Titanium coils... ;)
  • There was a post on this forum regarding some problems with the screws on the RTA - can't seem to find it now - but from memory it would seem that some of the threaded screw holes were misaligned so the screw was only clamping to one side of the orifice for the wire and would not always "grab" the wire, especially thinner ones.

    So for those having problems hold the thing up to the light before you build it and check that the little screws actually close off the wire holes properly.
  • @woodbar I've got several of the RTAs. None are misaligned, but some are not threaded deeply enough. The set screws in those don't seat against the wall of the holes.
    RTA Problem.jpg
    1200 x 900 - 625K
  • @Old_Salt I hope you have sent the faulty ones back then for replacement?
© 2017 Powered by Aspire