CF Sub Ohm will not turn on

Hey guys, new here to the aspire forums. I've used aspire products for over a year now and have never had an issue. Until recently I bought a CF Sub Ohm for my girlfriend, which she used for maybe a week. Soon after she told me that it wasn't charging, so I went to plug it in and no lights on the device came on, the light on the charger stayed green. I tried pressing the button 5 times on and off the charger, nothing happens. I tried putting a subtank on the device and trying to turn it on and still nothing happens? is there any way to fix this?
Comments
  • 2 Comments sorted by Votes Date Added
  • @Hjustin ,please use another charger to have a try.If the battery still can not be charged.(the light on the battery not light up,the light on the USB charger stay green)
    please go ahead our after-sale progress :
    Our after-sale process is :when consumer found what their bought is defective,they can firstly check the security code of their products on our website to confirm if it is original,When customer check the security code on our website,it should be original,no one check it before you.then ask the dealer for exchange,every dealer is responsible for their customers,we need the dealer's help,for we can not see the defective.when any quality problems occur, customers exchange from the seller,if the seller bought the products from us directly,they can ask us for replacement,if the seller bought the products from our authorized distributors,our authorized distributors will replacement it.

    We promised our directly retailers,we will send the replacements to them,we also require our authorized distributors that they need send the replacements to their directly retailers.

    If you bought the products directly from our online store,please send your problem to our online store support:online@aspirecig.com
  • Try charging it if it don't work try a new charger
© 2017 Powered by Aspire