Aspire ESP 30w reading "Check Atomizer"

I've had my Aspire ESP 30w battery and Atlantis 2 tank for about a month now. It worked perfectly fine until randomly one time after refilling my e liquid i screwed the tank back on and the battery said "Check Atomizer". I unscrewed and cleaned everything and even tried another coil. Nothing changed. I screwed my tank onto my brother's battery and it worked fine, so there must be something wrong with my battery. I recently noticed also that when i screw the tank onto my battery it can continue turning after it's all the way in and should have stopped. Any suggestions?
Comments
  • 4 Comments sorted by Votes Date Added
  • It can. If by not being able to properly secure the tank to the battery, the center positive pin may not be making a solid contact, which may cause a fault. The same goes for the threads, depending on how badly they are stripped.

    I've had other things with electrical threaded connectors, that if the threads were stripped, they just wouldn't make a proper connection and fail.
    Old_Salt
  • It sounds like you may have stripped the female threads on the ESP, if the tank keeps spinning and never tightens down. :(
  • That's what i kind of figured :/ but would that stop it from detecting the tank?
  • Okay, thank you :) i'll take it in and see if they can do anything about it without buying a whole new one
© 2017 Powered by Aspire