Aspire ESP 30w - can't adjust watts

My Aspire worked for about 2 weeks, and now it is stuck on 15w. The knob turns, but it stays at 15w. Any ideas?
  • 11 Comments sorted by Votes Date Added
  • I have the same problem except mine is stuck on 19w. It's the main reason why I'm on this forum, to find out what happened? And how to fix it. Would someone please help us out? Thanks.
  • please recharge the battery to have a try.
    If it is the same result.As Our after-sale process is :when consumer found what their bought is defective,they can firstly check the security code on our website to confirm if it is original,When customer check it on our website,it should be original,no one check it before you.then ask the dealer for exchange,every dealer is responsible for their products,we need the dealer's help,for we don't see the defective.when any qualiy problems occur, they can ask for exchange from their previous dealer.We will send the replacement to our authorized selles.
    We suggest customer to ask the seller for sevice,for we can not see the defective,if the seller confirm the product is defect,you exchange from the seller,if the seller bought the products from us directly,they can ask us for replacement,if the seller bought the products from our authorized distributors,our authorized distributors will replacement it.

    We promised our direclty retailers,we will send the replacements to them,we also require our authorized distributors tjat they need send the replacements to their direclty retailers.

    If our product is defective,the customer exchange from the retailer,if the retailer got the products from us direclty ,it can ask for the replacement from us directly,if the retailer got the product from our authorized distributor,it can ask replacement from our authorized distribtutor.
  • Hi Tina,
    Battery has been fully recharged several times but same problem remains: the watt number on screen does not change. It's stuck on 19w.

    I ordered my ESP30w from
    They have excellent customer service and I'm a loyal supporter of their products and business. When I received my ESP30w shipment,
    The first thing I did was check the security code on and confirmed it that it was an original. The tank I use for my ESP30 is my newly bought Aspire Atlantis 2 from Which has its own problems but I'll save that for another day.

    After reading your reply, and trying to understand it are you suggesting that I contact the sellers( for a replacement of my defective ESP30W? I'll keep you posted on how it goes.
  • mander said:

    I contact the sellers( for a replacement of my defective ESP30W?

    This is indeed what you have to do.

  • @Cegoca Thanks for your reply. I just finished submitting a ticket at Will keep everyone updated until a solution is found. That way everyone with the same problem will know what to do.
  • @mander The 'net has changed the way we do business. As a customer, you would normally be responsible for the shipping charges back to the vendor. Suddenly, something that was a bargain costs more than it would have been to buy locally.

    As a local vendor for another product, I often will provide warranty service for items bought through the 'net. I require a sales receipt, or copy of the e-mail confirming payment. This usually results in the customer having a working product much faster, and at much lower cost that shipping items back and forth to the original vendor. From my perspective, a new customer interested in the products I carry, comes to my shop. I may not make a sale at that time, but the customer usually will return to buy from me. It's worth the initial outlay to build a relationship with them.

    I don't know if Aspire allows this. Perhaps their team can comment. Can we deal with a different vendor for warranty service?
  • I'm having the exact same issue it would appear this is a manufacturing defect. I love the esp mod use it with my nautilus tank and it's a perfect match but it is now stuck at 13 watts and I usually vape it at 18 watts. It is fully charged and still having the issue I will be contacting the store I purchased it from tomorrow.
  • Anyone know of a fix for this? My seller is and they have a 30 day guarantee, I am left to solve this on my own, or my money was wasted, only used this mod for good, never thought Aspire would not stand behind this product, please e-mail me at [email protected], with a fix if you know of one.
  • Can I ask what resistance coil you are using? I have an old iStick 20W that will never get up to 20 Watts. If I put a 1.8 Ohm coil on it, it will max around 16 Watts. A 1.0 Ohm coil will max out around 12 Watts. I think it is really a variable voltage mod that shows wattage. My iStick 30W will always go up to 30 Watts, which seems to indicate newer technology and a chipset that is truly variable wattage. I have never used the ESP 30W, but it is an older mod...
  • Press fire button and - button at same time and it will unlock the wattage.
  • @zano A "-" button on an ESP30 ?
© 2017 Powered by Aspire