Battery Not Charing

Hi,

I have an CF Sub Ohm battery with an Atlantis tank and Aspire 4.2v/420mA charger, that I purchased 3 weeks ago.
The product worked fine originally the I am having difficulty both vaping and charging. I am not sure if the problem is with the charger or battery, or both.

When I plug the charger into the USB port of my laptop the light is always green. Whether I have the batter plugged in or not.

The battery appears to have charge (the switch turns blue when pressed and can be turned on or off with five presses). However when connected to the tank it does not fire / vape. When connected to the charger it does not appear to charge (the but button light remains off).

I have checked the connections on the tank and batter and both seem ok. I have also cleaned both connections.
I have installed a new coil in the tank and checked that it is firmly screwed in place.

Can anyone suggest what else I can do or what is going wrong?

Thanks.


Comments
  • 4 Comments sorted by Votes Date Added
  • Sometimes, my charger won't function on the USB (computer, NAS, laptop).
    The charger only functions with a wall adapter, even if it used to function on pure USB.
    So, if you have one, try that.
  • @Cegoca
    thanks for the response. I have tried the charger both in a USB port from a Mac and a wall charger for an iPad. Same problem on both of them. The light is always on green and does not charge the battery
  • Make sure that the wall adapter is rated for at least 5 volts.

    With the battery completely seated to the charger and plugged into the wall, the light is green...right? Try unscrewing the battery a revolution or so and see if the indicator light changes from green to red. Strangely enough, this is what I had to do. Good luck!
  • Also, have you tried another charger? Maybe the charger is defective?

    BTW, sometimes I also had to unscrew the battery a wee bit from the tank to get it to fire as well, good luck!
© 2017 Powered by Aspire